We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

500 Error During Installation - Try This. | Forum

John Feb 14 '14
Oxwall 1.6.0  refused to install on both my Wamp and hosted servers. None of the posts here helped and because I needed the script, I tried for several hours trying to figure the install out.

From what I can gather, the current install package my not be able to handle a variety of server types. I'm sure this will change in time.

Before I start, you will read that the line define('OW_DEBUG_MODE', false); in ow_includes/config.php should be set to true. Doing this at the start is useless because the installation package rewrites the config file and sets the value back to false. By all means do it once the script works if you're having further problems.

Secondly, The Installation Instructions refer to you having to change a line in the same config.php half way through the install process. Either this applies to older versions or it's not working in the install package I have. Nowhere was I asked to change anything. This possible oversight could also be the reason I wasn't able to install the script.

Anyway, after much trial and error the script installed, but it did take time. If you're also getting a 500 error after installing, you can at least try this:

Install the script in a directory and create a blank database as per the Install Instructions.

Run the script http://mysite/myfolder.com  You don't need to add /install at the end.

Site Settings - Fill them in. You should have no problem here. Click Next.

Database (Screen 1) - Fill in the database details. Click Next.

Database (Screen 2) should be blank. A message will only appear if the database contains data.  Click Next.

Finalizing - I received a message "Could Not Connect to Database". I found this interesting because the script had just checked the database to see if it was empty. - Instead of clicking Next, I used the Browser Back Key to return to the previous screen and clicked Next again.

Finalizing (Second time) - You shouldn't receive any messages this time. Click Next.

Plugins - I recommend you don't load any plugins yet. - Click Next.

In my case the script hung forever on Wamp and for two  minutes on my Server. The server eventually produced a 500 error. I just closed the script down in Wamp.

Next Step:

Restart the script  http://mysite/myfolder.com.

Site Settings - All or most of the site settings will be filled in. If not, just type the first letter in each box and select from the dropdown. This bit isn't too painful. Click Next.

Database (Screen 1) As above Click Next.

Database (Screen 2) Warning message that "Database should be empty". You can't go past this screen while the database contains data.

Open another browser tab and go to your hosting service C Panel. Go to MySQL and empty (Drop) the contents of the database. Do NOT delete the database. If you do, create a new one with the exact same name. Sorry, but how to do all this is beyond the scope of my article.

Close MySQL. - Your host may not like it being open while another source is trying to access it.

Go back to the install package, use your Browser Back Button to go back to the previous screen. Once there, Click Next

Database (Screen 2) should now be free of messages. Click Next

Finalizing - should have no warnings this time. Click Next.

Plugins - Do not install any plugins at this stage. They're very easy to install from your Oxwall Admin Panel. Click Next.

In 30 seconds or less, you should see the installed script.

If you think I've got it wrong, or you know of any shortcuts to bypass this, please post here.

Good luck.
The Forum post is edited by John Feb 14 '14
John Feb 14 '14

After writing the above, I discovered that the Avatar cropping facilities weren't there on my hosted server. I retried installing ten times following the above instructions. There are zero debug messages despite debug being on. The thing just wants to reinstall over and over again. The Install folder is not being deleted. I deleted it manually and that didn't help.

I tried twice with Wamp and had successful installs following the above. The Avatar function works fine and the Install folder is successfully deleted.

Both Config files look perfect. The thing that concerns me most is the installer saying it can't access the database when it did so just one screen before hand.

If I didn''t need this script, I wouldn't bother.

For anybody interested, here's the server error log. Hopefully that will help you. I'm only a novice and it's mumbo jumbo to me:


[Fri Feb 14 09:37:50 2014] [7876635] [core:error] [client] End of script output before headers: index.php

[Fri Feb 14 09:40:10 2014] [7876635] [fcgid:warn] [client] mod_fcgid: read data timeout in 120 seconds

[Fri Feb 14 09:40:10 2014] [7876635] [core:error] [client] End of script output before headers: index.php


Finally, there are 82 files in the DB. When it's installed properly there are 101.

The Forum post is edited by John Feb 14 '14
ross Team
ross Feb 17 '14
As to the Couldn't connect to database issue - it relates to the folder permissions. Some host do not let edit files, When you fill in the database details the form is being sent by POST method and it is empty, which is why you get this message. I'm really sorry, but what is your request about? You can't install the software locally or what? or is it just instructions for other users?
John Feb 24 '14
Hi Ross, I think I'm trying to say that like dozens of other people, I can't install Oxwall simply by pressing theInstall button.

My File permissions are perfect as far as I can see and so says FileZilla:
   ow_pluginfiles 777 recursive
   ow_static 777 recursive
   ow_userfiles 777 recursive
   ow_smarty/template_c 777

Please bear in mind that NONE of this is mentioned in the Install instructions anywhere on the site, so in all fairness - how important is this really?

It sort of reminds me of a hybrid car manufacturer failing to tell owners that for the car to run, they must fill the tank with methane gas.

Please keep in mind that:

- My permissions are correct
- My PHP and MySQL requirements are above the required levels.
- My servers (all three) are running Oxwall 1.53 okay. (Do I need to repeat that?)

The Install fails on all three servers in exactly the same way:
- Site info box (okay)
- Database info box (okay)
- Finalising Install (When I hit Continue, message "Could not connect the database"
- Use Browser back button
- Finalising Install (When I hit Continue - No message)
- Plugins (Leave all blank. Click Finish and eventually get 500 error.

Database propagated with 82 records, but Install directory not deleted.

The next step was:

- Enter URL again and enter Site and Database details again.
- Next screen (Database should be empty) So it IS connecting to the database, isn't it?
- Go to Mysql and empty database.
- Use Browser back key and go to Finalising Install. (no messages)
- Plugins (Leave all unticked)
- Script installs.

Sadly, this procedure only worked once on my hosted site but every time on WAMP.

To get the script to run on my hosted site alongside Oxwall 1.53 I had to do this:

1. Use a completely different server that had Softaculous. My server does not have Softaculous.

2. Install Oxwall on that server.

3. Copy files and DB SQL and transfer to my server and change permissions..

4. Modify Config.php and all worked perfectly - within reason.

You are more than welcome to tell me where I'm going wrong. Hundreds of people are waiting to hear.

The Forum post is edited by John Feb 24 '14
ross Team
ross Feb 25 '14
PM me your Cpanel access details, please. I'll take a look. 
John Feb 25 '14
Thanks for your kind offer. I'll set up a clean install tomorrow and send you everything so that you can access the site if successful.

It's come down to this:

No Debug Error Messages.

Server Errors:

[Tue Feb 25 08:07:51 2014] [7876635] [fcgid:warn] [client] mod_fcgid: read data timeout in 120 seconds, referer http://mysite.com/directory/install/plugins

[Tue Feb 25 08:07:51 2014] [7876635] [core:error] [client] End of script output before headers: index.php, referer http://mysite.com/directory/install/plugins

Using Chrome and FF

All directory permissions set to 755 and files to 644 except for ow_pluginfiles, ow_static and ow_userfiles which are 777 throughout. ow_smarty/template_c is 777 and the contained files are 644 using FileZilla.

I am not trying to load plugins.

Installation results in a 500 error after xx seconds timeout and the above error messages appear. This happens on all three servers, one of which is WAMP.

Maybe you can suggest something in the meantime?

The Forum post is edited by John Feb 25 '14
Guyto Feb 25 '14
Ok first off, let me state that the information provided by John, where he took his time to describe the technical issues that he is experiencing, is well versed. I am experiencing the exact same problem. I am a seasoned developer currently looking for the best OPEN CMS social networking software available online. OXWALL provides great tools and options verses the competitors (Dolphin, PHPFox, Buddypress, Ning, etc..) I have contacted my host to describe the issue with the 500 internal error. All the server settings meet the requirements to install Oxwall. The issue is not on their end. It has to do with the install script here. If many users are getting this error, I think it would be prudent to review the software to make sure that it is compatible for at least the minimum php settings requirement. (As drupal, Wordpress, Joomla, etc... do it). The install script contains very uncanny errors where the database, once all tables are created comes as being truncated or unable to connect. After 30 re-installs with no success, I decided that it was time for me to register and comment on this forum. The only person that made sense so far is "John". There seems to be a timeout error on the mod.fcgid through the php config file: "mod_fcgid: read data timeout in 120 seconds". Believe me when I state that I have tried all possible solutions to install Oxwall ver 1.6.0. None Work.

You do have a great platform here and patches or solutions should quickly be found to remedy this issue.
ross Team
ross Feb 25 '14
Guyto, you can also PM me your Cpanel access details and I'll take a look at the issue. 
Olivier May 14 '14
I'm also experiencing the same problem when trying to install oxwall v1.6 on a windows' wampserver. Any news since John's post ?

ps: I successfully installed oxwall v1.6 on a debian server the first time I tried, but never after a dozen of times on a windows' wampserver.

The Forum post is edited by Olivier May 14 '14
John May 14 '14
Hi Olivier, Sad to say Oxwall does NOT run on my WAMP server and I've given up. I thought I had the answer but something would always go wrong.

It does seem to run okay on Ampps when you install it using softaculous.


ross Team
ross May 14 '14
John, Olivier, 

I have just installed Oxwall 1.6 on Wamp

wamp version 2.2e

php - 5.4.3

apache - 2.2.22

mysql - 5.5.24

windows 7

The only problem I ran into is that I had to enable mod_rewrite. Sorry we cannot reproduce any of the errors you mentioned. 

We need as many details as possible from you. 

Olivier May 14 '14
I remember having installed oxwall on a previous version of wamp and it did the trick, but now I'm on :

Apache : 2.4.9

MySQL : 5.6.17

PHP : 5.5.12

PHPMyAdmin : 4.1.14

SqlBuddy : 1.3.3

XDebug : 2.2.5

(tried on Win7 & Win8.1)

ross Team
ross May 14 '14
Yes I see that, but we need error logs, apache logs, on which step you have problems? what exactly happens. We need as many details as possible to reproduce the error, because now we have nothing to fix. 
Olivier May 14 '14
It's the exact same problem John mentioned. No more, no less.
John May 15 '14
Ross, I have documented this elsewhere because the same problem also happens on several servers, one of which you've checked and said some routine was timing out.

In a nutshell, you go through the install and get an error on the third or fourth screen saying the script cannot access the database.  You go back to the previous screen and on the next try it does access the database. Then on the last screen after installing NO plugins, the script loops and loops and loops and loops. It will continue to do so for several hours if you allow it.

You may have rewritten Mod_rewrite, but there doesn't seem to be any documentation saying you should do this before installing the script.

I eventually got it running on WAMP as per my very first post, but future install attempts failed. A Google search would indicate that Oxwall won't run on Wamp. Every other script I have does.

I must have tried 50 - 100 times before discovering Ampps. It seemed to work fine on that server as far as I could see, but a recent install was showing problems such as getting a "Page Not Found" Error whenever I run Oxwall. I can still login and everything then seems to work okay.
Olivier Jun 12 '14
Quote from ross


I have just installed Oxwall 1.6 on Wamp

wamp version 2.2e

php - 5.4.3

apache - 2.2.22

mysql - 5.5.24

windows 7


I also tried with the same wampserver version, but oxwall 1.6 need php5.4.4 min.

Anyway, I tried with easyphp, xammp and >5 wampserver versions and when it has been installed (except with wamp), it was just unusable for development (few seconds to more than 30 s to change from a page to another). I then installed a VM (Debian wheezy x64 as guest) under VMWARE (windows 8.1 x64 as host) on a AMD zacate e-450 4Gb RAM and it is just as smooth as my prod server (debian wheezy as well) is. So wierd....

ross Team
ross Jun 12 '14
I'm sorry Olivier, but there's something wrong on your side, because we cannot reproduce the error, especially on wamp 2.2.e. The site is running good, no problem with installation at all. We can't tell you what exactly is wrong, because we need to test the problem on your PC and it is not possible. 
Alex Jun 22 '14


Firstly, excuse my english, I'm using Google Translate.

I am an experienced user, already installed and use various PHP scripts, including my site with the previous version of Oxwall this work perfectly.

As I moved the domain, tried a new installation.

I'm trying to install three days, when not giving error when connecting to the database, the error:


"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform Them webmaster@social.amigolhes.com of the time the error occurred, and anything you might have done that may have Caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request. "


I'm using Dreamhost.

Thank you.

ross Team
ross Jun 22 '14
Alex, please check your server error logs, as it seems server related issue
Alex Jun 22 '14
ross, Good night. 

First let me tell you something. 

I just installed version 1.5.3 and was on the first attempt. This working perfectly. (Look www.social.amigolhes.com

How can? I am sure that the problem is version 1.6.0, where many people are having problems.


Pages: 1 2 »