We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

zend_mm_heap corrupted [Solved] | Forum

Chris_W
Chris_W Oct 11 '15
I have three Oxwall sites running, just lately I am getting this error when the cron runs on all three "zend_mm_heap corrupted" it has only started happening since the last platform update.

I have other php scripts running from cron which are unaffected, so I'm pretty sure it is something in the Oxwall php that's triggering the error.

Any ideas as to what might be causing the error would be appreciated. I have added zend.enable_gc = 0 (on the advice of my hosting support) to the end of the cron commands, to try and stop the error without success.
The Forum post is edited by Chris_W Oct 17 '15
ross Team
ross Oct 12 '15
it has nothing to do with the update or software itself


it is a very low level error related to the zend php engine, you need to contact server support or search info on the internet

Chris_W
Chris_W Oct 12 '15
That doesn't explain why I have nine cron jobs that run php scripts. Three that make backups, three that create sitemaps and three Oxwall sites, only the Oxwall site cron jobs give this error, and only since the last platform update.
Chris_W
Chris_W Oct 12 '15
Interesting;

If I call the php script locally
"/usr/local/bin/php /home/******/public_html/nellbrydenfans.com/ow_cron/run.php"
I get the error and the script fails.

If I call it via curl
"curl --silent --show-error http://nellbrydenfans.com/ow_cron/run.php >/dev/null 2>&1"
It runs OK
The Forum post is edited by Chris_W Oct 12 '15
ross Team
ross Oct 13 '15

Chris you need to set USE_ZEND_ALLOC=0 in your environment for your cron command you're running on the server


Also, make sure debug mode for cron is disabled in config.php


What is your php version

Chris_W
Chris_W Oct 13 '15
php is 5.3.29 soon to be updated to 5.5
ross Team
ross Oct 14 '15

Chris you need to set USE_ZEND_ALLOC=0 in your environment for your cron command you're running on the server


Also, make sure debug mode for cron is disabled in config.php

Chris_W
Chris_W Oct 14 '15

Quote from ross

Chris you need to set USE_ZEND_ALLOC=0 in your environment for your cron command you're running on the server


Also, make sure debug mode for cron is disabled in config.php


Thanks Ross.

Debug disabled. Running the cron via curl at the moment with no errors. Any idea why it works error free with curl but not when called via php in a local path?

I will try switching one of the sites back and adding USE_ZEND_ALLOC=0 and see what happens.
ross Team
ross Oct 16 '15
Our devs think that different commands use different php.ini, therefore different settings of php, which is why you get the error while running cron via local command and no error via curl
Chris_W
Chris_W Oct 17 '15
In case anyone else gets the same problem, here is the cron command that worked for me.

export USE_ZEND_ALLOC=0 && php -q /home/username/public_html/red-sky-july.com/ow_cron/run.php >/dev/null 2>&1
ross Team
ross Oct 18 '15
Thanks for letting us know.