We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Website crashes when this is activated (500 error) - Group Cover | Forum

Tecca Nov 18 '15
Message: Can't generate URI! Route `gheader-settings-page` not found!
File: /var/www/example.com/public_html/ow_core/router.php
Line: 262
That seems to be the only error message I can find. I've tried re-uploading the plugin several times but it makes the site hit a 500 error regardless. I have to rename the folder in the ow_plugins folder to access the site again, which is probably why the error above shows.
The Forum post is edited by Tecca Nov 18 '15
Sergey Kambalin
Sergey Kambalin Nov 18 '15

The error is a result of renaming the plugin directory. Rename it back, then enable DEBUG MODE and open your site. You will see error message, send me this message.

If you do not know how to enable debug mode:


The Forum post is edited by Sergey Kambalin Nov 18 '15
Tecca Nov 18 '15
Yep, I've given that a shot, no errors seem to be shown, only that the site white-pages to a 500 error. I'll have to uninstall each plugin and see if something's conflicting with this plugin. I'll report back when I find something (or if I don't).
Tecca Nov 18 '15
This is actually the error I get when I activate the plugin, from my Nginx logs:

[error] 11837#0: *38246 FastCGI sent in stderr: "PHP message: PHP Fatal error: Class 'GHEADER_Plugin' not found in /var/www/example.com/public_html/ow_plugins/gheader/init.php on line 14" while reading response header from upstream, client: xxx.xxx.xx.xx, server: www.example.com, request: "POST /base/ping/index/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.socket:", host: "www.example.com", referrer: "https://www.example.com/admin/plugins/index"

Every time I activate the plugin, it causes the site to crash with a 500 error, then after deactivating the plugin, I cannot access groups. It only happens when trying to enter a specific group's link, and it will redirect to the 500 error page within the site. This can't be fixed until I uninstall the groups plugin and reinstall. Trying to activate a clean install of the group cover plugin reproduces this every time.

The Forum post is edited by Tecca Nov 18 '15
Sergey Kambalin
Sergey Kambalin Nov 19 '15



Replace this code:

require_once 'plugin.php';

with this:

require_once __DIR__ . DS . 'plugin.php';

After this changes, plugin.php will be included by absolute path not relative. It should fix the error.

The Forum post is edited by Sergey Kambalin Nov 19 '15
Tecca Nov 19 '15
Awesome, that fixed it up. I have your other plugins on my radar as well, thank you for supporting your work!

This is resolved.

You do not have permission to reply this topic