We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Chamial Oxwall Fork | Forum

Terry Webbs
Terry Webbs Jun 28
Quote from Patricia Zorrilla Bcn

I can not find a way to know if the OxWall / Chamial standard tables are created in UTF8 or UTF8mb4 so that the plugins create them with the same coding system.

My idea is to read the coding system of -for example- ow_base_user so that the new tables are created in the same format.

Since this is only indicated when creating tables, and not when they are used or destroyed, perhaps a plugin can be made that alters all those created by plugins, because I believe that you can not mix both systems on the same base.

I think that Chamial should ask in which coding system is going to be installed and leave it in a DEFINE in config.php, so the plugins in the future could create their tables in the same format.

To test the Chamial latest version I had to edit the source code because my server does not support UTF8mb4. I guess I can ask the hosting to change this, but I do not see the incentive: for the user it only changes the power to use Asian characters and unicode emojis higher than 0x10FFFF



MyPhpAdmin on cpanel 
  • Server charset:  UTF-8 Unicode (utf8) across all tables

Oxwall / Chamial use the standard tables


Chris_W
Chris_W Jun 28
In phpMyAdmin mine is set to utf8mb4_unicode_ci and 5 sites work okay.
The Forum post is edited by Chris_W Jun 28
Marco
Marco Jul 3
I try to understand here what i need to do:
I see in install sql that all is set to:
CHARSET=utf8;

and 1 table: base_question_to_account_type is set to: CHARSET=latin1;


If i check this with original oxwall sql file then i see the same.

Webster Molaudi
Hi there,


I just upgraded to version 1.9.8 but now my opegraph to Fb is not working, it just picks up my default opengraph on oxwall not the pages....See here


This is the actual link - https://www.myvirgo.info/ynnews/news/view/rihanna-backs-sudanese-protesters


What could be there issue ?

Marco
Marco Jul 4

Quote from Webster Molaudi Hi there,


I just upgraded to version 1.9.8 but now my opegraph to Fb is not working, it just picks up my default opengraph on oxwall not the pages....See here


This is the actual link - https://www.myvirgo.info/ynnews/news/view/rihanna-backs-sudanese-protesters


What could be there issue ?


We have to look into this. I think the problem is with plugin and not with core probably
Webster Molaudi
Nevermind i found and fixed the issue...The update had put my site on maintenance mode.

Since i was logged in i could not see it until i used another device and noticed that :).

Chris_W
Chris_W Jul 6

Quote from Webster Molaudi Nevermind i found and fixed the issue...The update had put my site on maintenance mode.

Since i was logged in i could not see it until i used another device and noticed that :).

The script used to put the site into maintenance mode for the update, then switch it back afterwards, but I have found that lately on four of my five sites, it no longer switches it back after update. I have no idea why it works on one site but not on the others.
Marco
Marco Jul 9

Quote from Chris_W
Quote from Webster Molaudi Nevermind i found and fixed the issue...The update had put my site on maintenance mode.

Since i was logged in i could not see it until i used another device and noticed that :).

The script used to put the site into maintenance mode for the update, then switch it back afterwards, but I have found that lately on four of my five sites, it no longer switches it back after update. I have no idea why it works on one site but not on the others.

a
Quote from Chris_W
Quote from Webster Molaudi Nevermind i found and fixed the issue...The update had put my site on maintenance mode.

Since i was logged in i could not see it until i used another device and noticed that :).

The script used to put the site into maintenance mode for the update, then switch it back afterwards, but I have found that lately on four of my five sites, it no longer switches it back after update. I have no idea why it works on one site but not on the others.

ny difference in php versions?
Clem Fandango

Quote from Marco We are working on PWA app and mobile app.

I would be happy to donate to the cause for a mobile app. Name your price. Mobile apps are the difference between failure and success of a website these days.


I have registered for your site (SixFoot). Please approve my membership.

Chris_W
Chris_W Jul 9
They are all on the same server, with php 7.2
The script used to put the site into maintenance mode for the update, then switch it back afterwards, but I have found that lately on four of my five sites, it no longer switches it back after update. I have no idea why it works on one site but not on the others.

Any difference in php versions?

The Forum post is edited by Chris_W Jul 9
Defunct
Defunct Jul 11

Quote from Clem Fandango
Quote from Marco We are working on PWA app and mobile app.

I would be happy to donate to the cause for a mobile app. Name your price. Mobile apps are the difference between failure and success of a website these days.


I have registered for your site (SixFoot). Please approve my membership.


Revamped, Full Hybrid App Plugin (Android, iOS, PWA) once it's approved in the store:
https://developers.oxwall.com/store/item/1643
Marco
Marco Jul 11
For those who are interested:

We today released a new version for chamial.

Easy update your oxwall installation with our patch:

https://www.chamial.com/docs/faq/oxwall-to-chamial/patch-oxwall-to-chamial/

Latest information about latest release:

https://www.chamial.com/chamial/new-release/chamial-version-1-9-09-released/
The Forum post is edited by Marco Jul 11
Clem Fandango
Clem Fandango Jul 11
If I update to Chamial, am I to understand that I should also change my PHP version from 5.6 to 7.2? Will the plugins remain compatible/stable under 7.2?
The Forum post is edited by Clem Fandango Jul 11
Clem Fandango
Clem Fandango Jul 11

Quote from AppXprt
Quote from Clem Fandango
Quote from Marco We are working on PWA app and mobile app.

I would be happy to donate to the cause for a mobile app. Name your price. Mobile apps are the difference between failure and success of a website these days.


I have registered for your site (SixFoot). Please approve my membership.


Revamped, Full Hybrid App Plugin (Android, iOS, PWA) once it's approved in the store:
https://developers.oxwall.com/store/item/1643

Can you show me some screen shots while we wait for the store approval?
iola Sweden
iola Sweden Jul 11
i feel thing are going in the right direction. 


""Mobile apps are the difference between failure and success of a website these days""


totally agree.


skadate success with design and failure with: PWA app performance and to change design you self easy in admin settings plus they close door for many third part plugins totally.


i think all depending on how many people working on the software. i must take very much of time create beautiful apps with good performance on 3 platforms

The Forum post is edited by iola Sweden Jul 11
Marco
Marco Jul 15
No not necessary but we recommend to update to php 7
Quote from Clem Fandango If I update to Chamial, am I to understand that I should also change my PHP version from 5.6 to 7.2? Will the plugins remain compatible/stable under 7.2?

Defunct
Defunct Jul 15
I would suggest 7.2 as it's much quicker
Rob
Rob Jul 15

Quote from Exclusive I would suggest 7.2 as it's much quicker
Our experience now, 7.2 indeed works perfectly.!
Patricia Zorrilla Bcn
I think that OxWall is nothing more than the base on which plugins work, Rob, if everything works correctly, it would be good if you said what plugins you use. It would also be nice if before making sure everything works, you checked it with the "debug mode" activated. You can not go publicizing "do this that works well for me" if the "works well" is not checked at all. There are good, bad and regular plugins. It is not that I am against using more modern versions of PHP ... But you have to consider that many people use old plugins of developers that will not give support. 
Rob
Rob Jul 16

Patricia, we also use old plugins such as "New User Alert" from "Purusothaman Ramanujam" which according to our information is no longer active as a developer for this purpose.

This plugin works well with us, also under Php 7.2.

Yes, we too sometimes experience problems and luckily they have all been solved so far.


Anyway, we are not developers and only buy themes and Plugins so maybe we should not make any announcements about how something works or not.


With regards,


Rob

Pages: « 1 2 3 4 5 6 7 8 9 10 11 »
This topic is locked