We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Adding custom code to Origin theme. | Forum

Topic location: Forum home » Development » Themes
Thomas Cox
Thomas Cox Apr 2 '13
I'm trying to add 2 gives to my <div class="ow_page_container">

{content}

</div>

in dndindex.html


It looks like

<div class="ow_page_container">


<a href="http://google.co.uk/" target="_blank"><div id="left-adds">left ads</div></a><a href="http://google.co.uk/" target="_blank"><div id="right-adds">right ads</div></a>{content}</div>


I've saved it into the themes master pages folder but my custom code isn't showing, any help?

The Forum post is edited by Thomas Cox Apr 4 '13
Michael I.
Michael I. Apr 3 '13
Topic was moved from Custom Code Modifications.
Thomas Cox
Thomas Cox Apr 3 '13
...anyone?
Thomas Cox
Thomas Cox Apr 4 '13
Getting really frustrated with this.
Thomas Cox
Thomas Cox Apr 7 '13
*tumbleweed*
Igor
Igor Apr 8 '13
Thomas Cox have you tried enabling DEV mode? 


What kind of result was expected?

Thomas Cox
Thomas Cox Apr 8 '13
Yep, put it in dev mode with the custom links in the theme master pages and still nothing :(
Igor
Igor Apr 8 '13
I have tried to use your code in dndindex.html and it got displayed on my main page. 




I believe that if proper styles have been added to those <div>s, they would have displayed correctly. 


You don't even get to the page from my screen shot ?

Thomas Cox
Thomas Cox Apr 8 '13
Quote from Igor I have tried to use your code in dndindex.html and it got displayed on my main page. 




I believe that if proper styles have been added to those <div>s, they would have displayed correctly. 


You don't even get to the page from my screen shot ?


I can't even get the code to be inserted into the HTML page, would it be possible to talk on skype for a bit of assistance?


EDIT:

I tried the Darklets theme and they're showing on there, it must be something to do with the Origin theme.

The Forum post is edited by Thomas Cox Apr 8 '13
Thomas Cox
Thomas Cox Apr 8 '13
I'M A FREAKING IDIOT I TOGGLED DEV MODE OFF AND FORGOT ABOUT IT ARGHHHHHHHHHHHHHHHHHHHHHHHHHH

Days of frustration over nothing!!!

My bad :(

Igor
Igor Apr 8 '13
))  happens to me all the time!!! those little things drive me mad. 

Glad to hear that everything works. 

PM me if you will need any help in future. 

Ana Rosa
Ana Rosa Apr 12 '13

ola


sou nova no desenvolvimento....eu preciso modificar o origin e nao estou conseguindo.


o que é preciso fazer antes de modificar os arquivos em themes master pages ?


porque eu fiz as modificações e nao tive resultado....

Ana Rosa
Ana Rosa Apr 12 '13

hello


I am new in development .... I need to modify the origin and'm not getting it.


what needs to be done before modifying files in themes master pages?


because I made the changes and I had no result ....

Thomas Cox
Thomas Cox Apr 12 '13
Quote from Ana Rosa

hello


I am new in development .... I need to modify the origin and'm not getting it.


what needs to be done before modifying files in themes master pages?


because I made the changes and I had no result ....


Go to ow_includes/config.php


There will be 2 lines that have

define('OW_DEV_MODE', false);


Change both of them to

define('OW_DEV_MODE', true);

Ana Rosa
Ana Rosa Apr 13 '13
Hello


Tnks! thats works!!!


Do you now how to  changes the base.css of the theme to adapte to the new update?


I use the theme cherry and must continue using this. 

This theme was equal to the default theme, just changed the colors, but after updates it does not fit .... I've modified a few things and it worked .... but not have the entire list of changes for 1.5.2

Alexander Mirvis
Hey guys... You don't need DEV mode enabled. 


Download https://developers.oxwall.com/store/item/579


This plugin. It's a Cache eraser. After you change the code, delete all the cache and it will pop up.