We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Permissions Issue [Answered] | Forum

James Nov 19 '13
Hi - Desperately need some help with this one please.


Running Platform version 1.5.3 (build 6341) with MyDiary theme.

Permissions set to 777 on ow_pluginfiles, ow_userfiles, ow_static and ow_smarty/template_c.

Site is currently in a subfolder while it is being developed


The entire site is working fine aside from a single issue - users cannot edit their profiles. They can open profile, see profile to edit but as soon as they click save, IE says "403 This website requires you to log in." and Chrome just says Forbidden. Same for Admin account.

This (seems!) obviously a file permission thing somewhere but no idea where to start looking. Post below suggests contacting hosting company but which part do they need to update? http://www.oxwall.org/forum/topic/6865

The profile questions have been added to and some answer options changed but all via the panel, not in code. 

Any suggestions VERY gratefully received!

The Forum post is edited by Alia Dec 12 '13
Alia Team
Alia Nov 20 '13

1. Check your server's error logs.

2. Just in case deactivate all third party plugins. Try editing the profile again. Same issue?
If yes, then reactivate all plugins.
If issue disappears, then one of the plugins was causing this. Activate plugins one by one and check your site after activating each plugin.

James Nov 20 '13

I resolved the issue. It was actually caused by the URL question in the profile - possibly a bug?

The URL auto fills the answer with '' For some reason this was causing an issue. I swapped the question with a plain text response, instructing users to just use www.domain.

This solved it.

Thank you for looking at this.

Alia Team
Alia Nov 21 '13
Thanks for sharing James.

To сheck whether it is a possible bug I created a new field of "Text" type in admin panle>>profile questions.
Then as a user went to "Edit my profile" and entered site URL with "" . All went well.

How do you get the field to auto populate with ''. Was it some kind of custom modification of yours?
James Nov 21 '13

No, the standard URL question populates the automatically. Even if I just type the www.domain, in the answer,  it shows with on the profile. I think like you, I swapped URL for simple text question and worked okay.

Alia Team
Alia Nov 21 '13
I think that I am missing something...
Oxwall doesn't have standard "URL" question. That is possible why I can't reproduce the issue. May be you are using some kind of plugin that adds this profile question?
James Nov 21 '13
Oh .. I haven't knowingly installed a plugin to do this but obviously one of mine adds URL.

To help I have attached my Profile Question page and all the active and inactive plugins I run.

Sorry - because I didn't go looking for this feature I assumed it was default - not much help :(

  ProfileQuestions.GIF (89.6Kb)
  ActivePlugin.GIF (34.29Kb)
  InactivePlugin.GIF (47.41Kb)
Alia Team
Alia Nov 25 '13
James, sorry, this was my fault.
Oxwall indeed has "URL" type of field.
Tested on windows 8, IE10 and was not able to reproduce the Forbidden message.

Most likely the issue is with your server settings.

In any case, you found an alternative solution yourself, but if you would like to investigate further why "URL" type of field was causing the error message, let me know.