We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Top-right menus not working | Forum

Peter May 18 '14
See http://community.jvlog.org/

Menus in top-right corner stopped working on certain pages. They appear, but sign-in does not pop out a window, and the drop-down ones do not drop down. I found a couple of other threads reporting this, but there was no clear solution given. I think they use a unique ID generated based on the time at some point, and several may be using the same ID.

FYI, I am using CloudFlare with Rocketscript enabled. I suspected it may be an issue, but I use it on other Oxwall sites and haven't had a problem.

Is there a way to fix this? It's the only thing stopping us for deploying the site.


The Forum post is edited by Peter May 18 '14
ross Team
ross May 18 '14

I just tested it the sign-in pop up windows works

Peter May 19 '14
It's erratic/random. Click "MEMBERSHIP" and then "MAIN" and try it.


User: test
Password: bingo

Here's the best description I can figure out.

Initial load with no browser cache it is OK. If you go to another page, then the top menu on the MAIN and DASHBOARD pages no longer work. Ditto for the ajax text entry box for status updates on those pages. Everything seem to work OK except on those two pages.

It appears to be some sort of ID conflict between the top right menu and the status update box. If I remove the newsfeed from those pages, they work OK. I tried things like disabling / enabling plugins, re-saving page customizations (e.g., the newsfeed boxes), etc., in hopes it would rewrite whatever is conflicting.  No luck. :(

Any suggestions greatly appreciated!

The Forum post is edited by Peter May 19 '14
ross Team
ross May 20 '14
Peter, can you please disable question/polls plugin and any plugin related to the newsfeed and try again. 

What if you disable cloudlflare? does the issue persists?

Peter May 20 '14
If I DISABLE all plugins EXCEPT the newsfeed, the problem still exists.

If I ENABLE all plugins EXCEPT the newsfeed, the problem goes away.

Could it be one of the status updates in the newfeed, some bad HTML in it or something? Is there a MySQL table I can drop to remove them? Trying to do it manually from the UI would be a long process.

I have tried disabling CloudFlare and didn't notice any change.

The Forum post is edited by Peter May 20 '14
ross Team
ross May 21 '14
what software version and newsfeed plugin you have?
Peter May 21 '14
Chris, thanks for confirming I wasn't crazy. LOL ;)

Ross, it seems to have cleared up. What caused it I don't know, but I suspect it was hard to trace/test because of caching -- by Oxwall, the browser, CloudFlare, and possibly even by my ISP. 

For the record, it was database related. This started after I did a database export from our old Oxwall installation, installed a fresh copy of Oxwall, and then imported the database. All was OK with the fresh install until I switched to the production (old) database.

Thanks for the help. I'll keep an eye on it an see if it crops up again. Hope not, 'cause Oxwall is impressive, and I'm looking forward to rolling this out. Thanks to everyone who contributes to this project!

The Forum post is edited by Peter May 21 '14
Peter May 21 '14
Darn, may have spoke too soon. It's still happening in Firebox. Cleared cache, re-started, etc.

Seems to be OK in latest versions Opera, Chrome and IE.

If any Firefox users want to test (to see if it is actually browser related or just something weird on my local system):

1. Go to http://community.jvlog.org/

2. Click a couple of the links at the top.

3. Now click MAIN and then see if the SIGN IN link in the upper-right corner works.

The Forum post is edited by Peter May 21 '14
bobbi May 21 '14
i tried you site on firefox version 29.0.1 main page the sign in box does not open it is hit and miss it opens on some pages but not all, have you tried downloading a older version of firefox

i then tried safari the sign in box opens up straight away
Peter May 21 '14
Thanks, Chris!

That narrows it down to NOT being a localized issue with me alone.  Hopefully, this will give the developers enough info to help trace down the problem. I'm suspecting some kind of ID conflict between the upper-right menu and the ajax text-entry box on the newsfeed.

Ryan P
Ryan P Jul 29 '16

Just found this forum post. I am currently having this issue with Firefox on my site. I cannot access/view options dropdown list when hovering the top right panel i.e. admin panel/profile/messages. I thought this was simply a browser issue, since all works well using Chrome, Explorer, & mobile. 

However, it seems to work fine on this site & forum using Firefox. Could there be something wrong with my setup, or perhaps a plugin issue? Thanks

Darryl B Leader
Darryl B Jul 29 '16
I have experienced the drop downs not working due to some script I had in the head section at one time. It could be a plugin incompatibility issue as well. I am using Firefox, and don't see this behavior.
Aliya Team
Aliya Aug 1 '16
@Ryan P , please provide your site URL.

This indeed sounds like a js conflict. You must troubleshoot with Firebug for Firefox.
Link: https://wiki.oxwall.com/faq:parse-error-troubleshooting