We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

move new vps 500 error running php 5.4 | Forum

dave Leader
dave Aug 6 '14
Moved a site to new vps getting 500 error running php 5.4,  

its not permissions i just redid them all, 

its not owner because permissions fixed that part,

its not htaccess as i renamed it and still nothing,

its not php ini as i renamed that and still nothing,


there are no errors in the log at all, 

i have both debug and  dev mode on and i have refreshed the cache.


any ideas what i can try next.. ;)

The Forum post is edited by dave Aug 6 '14
ben
ben Aug 6 '14
hi dave, did you update your oxwall or only moving your entire site to new server without doing an update? have you seen apache error log?
tammy harris
tammy harris Aug 6 '14
Development and debug don't work together you need to pick one
dave Leader
dave Aug 6 '14
sorry my email has been down for hours lol  


ben, nope didnt update just moved it is all... im thinking maybe it wont run on 5.4 does anyone have it on php 5.4


tammy wow i never new that, thanks yep i will.. 


if i cant get it soon, im gonna send them my info and have them look. 



dave Leader
dave Aug 6 '14
do i have to have PDO installed on my server?
dave Leader
dave Aug 6 '14
yep i think that might be it..  i forgot to install pdo and mbstring also 


http://www.oxwall.org/forum/topic/4900

dave Leader
dave Aug 6 '14
yep that were it lol.... fires right up... how about that i actually got thru a whole day without breaking something and fixed something instead hee hee.. 
Daisy Team
Daisy Aug 6 '14
Dave, if you are talking about the 500 Internal Server Error page, this means that the server is misconfigured in some way. You should check if you have mod_rewrite module is installed and configured correctly at your server. To check if the problem in the mod_rewrite, try to rename the .htaccess file and check if the problem disappears. If so, you should check the apache settings.
dave Leader
dave Aug 7 '14

Thanks Daisy, 


Yeah i got it up and running it was the pdo and mbstring that i forgot to install so i added them and rebuilt apache and it came right up.   Now its just a matter over the next week to get all the server warning tweaks done, this morning i had messages of resource usages of the cron running at over 200MB, it was 299 and 305 mb so i was alittle off on my settings. 


One thing Daisy that i will say, loading the PDO and the mbstring was a stroke of luck that solved the problem, i got no error message that said so, nothing at all to indicate what it was.  I was totally flying blind, and the only reason that i got the PDO idea was because my WHMCS host billing software posted a message that i needed to have mbstring installed.  So while i was going down the list of features to add to apache i ran across PDO feature and i thought "mmmmmm i wonder"  and thats when i posted the message asking about PDO, then i found the requirements and luckily that was it. 


I know that you have the requirements page and that should keep some of this from happening but it sure would be nice if one day Oxwalls error reporting would include the items in the reqirements page in full.  That would have saved me a ton of time if i would have received something that said PDO and mbstring were not found ya know.  :)  I feel if its a requirement it needs to have some kind of error reporting attached to it.


It will take about a week for everything to settle into the comfort zone with some tweeks here and there but looking good for now.   I am so glad to finally get these sites on a VPS, i am going to test some vid uploads in the next couple of days to see how much that has improved. 


My shared server was doing about 3MB per min and i dont expect an improvement because its more about ISP upload speed than it is server, but maybe with the VPS i can squeeze a bit more out of it, even 5MB a min would be a huge improvement and members will be very happy with that for awhile im sure.


Thanks everyone for the replies.  ;)

The Forum post is edited by dave Aug 7 '14
tammy harris
tammy harris Aug 9 '14
dave u mentioned video uploads have you managed to get video uploader working on 1.7
dave Leader
dave Aug 9 '14
im still working on getting everything back running.