We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Cron Running But Not Working | Forum

Keelan Leader
Keelan Oct 20 '11
So i moved to a VPS as i want to use one minute crons and the chat as it is resource heavy.

So now my crons are running, my host showed me a log of it running every minute but my users still say logged in all the time.

I don't understand :(

/usr/bin/php -q /home/habbohub/public_html/ow_cron/run.php
The Forum post is edited by Keelan Oct 20 '11
GH Oct 20 '11
I still cant get my cron stuff right, its really the only thing holding me up right now. But my issue is that my crons dont seem to fire at all.. I have the provider working on it..

BTW, what does the -q flag do?

Keelan Leader
Keelan Oct 20 '11
-q will prevent cron from sending you an email every time the script runs.
Den Team
Den Oct 21 '11
Would you login via SSH to your account and run cron command manually:
/usr/bin/php -q /home/habbohub/public_html/ow_cron/run.php

Will you see any errors?
Keelan Leader
Keelan Oct 21 '11
root@one [~]# /usr/bin/php -q /home/habbohub/public_html/ow_cron/run.php
root@one [~]# 

No errors... Didn't log out users though when they aren't online.
The Forum post is edited by Keelan Oct 21 '11
Keelan Leader
Keelan Oct 22 '11
FYI one min cron jobs for other software works.
Den Team
Den Oct 24 '11
Hmm... try to enable DEBUG_MODE and DEV_MODE in ow__includes.config.php file and run cron command again.
Did you set 777 recursive permissions for ow_userfiles and ow_pluginfiles folders after migration?
Keelan Leader
Keelan Oct 24 '11
Debug on dev on, 777 already on them folders. No luck.
Den Team
Den Oct 25 '11
Well, send me your FTP/CPanel/Site admin details. Our dev team will check 

P.S. please, attache link to this topic ))
Sachin Jan 15 '12
I am getting "permission denied" error while running cron. 
I have enabled DEBUG_MODE and DEV_MODE in ow__includes.config.php file.  Also  ow_userfiles and ow_pluginfiles folders have 777 recursive permissions by default.
Michael I.
Michael I. Jan 16 '12
How does your cron command look like? Can you paste it here?
Dayanand Sutar
Dayanand Sutar Jan 16 '12
Below is my cron command.

Michael I.
Michael I. Jan 20 '12
It should actually look something like this:

/usr/bin/php -q 

Did you check the Cron setup manual?
Michael I.
Michael I. Jan 20 '12
Topic was moved from Bug reports and troubleshooting.