We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software


Ulises Aguilera
Ulises Aguilera Feb 7 '15

How can agregrate the Slide Show Plugin in the User Profile Page, and in the User Dashboard Page?

ross Team
ross Feb 8 '15
Topic was moved from General Questions.
Oxwall Tips
Oxwall Tips Feb 12 '15
You will need to modify activate.php file of the Slideshow plugin.
More info on adding widgets can be found here: https://docs.oxwall.org/dev:begin:widget#adding-a-widget

In activate.php file of the SlideShow plugin lines responsible for adding this widget into User Profile and Dashboard pages are commented out. Try uncommenting them and check whether this works out.
The Forum post is edited by Oxwall Tips Feb 12 '15
Ulises Aguilera
Ulises Aguilera Feb 12 '15
Ok, thanks, Ill try, let me see If I can do this, I will back to comment in the page you gave me.

So long Pal.
Ulises Aguilera
Ulises Aguilera Oct 25 '15
Could you please be more clear? Because I can´t follow you. Could you explain me step by step and teach me some samples? please?

Darryl B Leader
Darryl B Oct 25 '15
At the bottom of the activate.php file in the root of the slideshow plugin "ow_plugins/slideshow/activate.php" you will see these lines
$cmpService->addWidgetToPlace($widget, BOL_ComponentAdminService::PLACE_INDEX);
//$cmpService->addWidgetToPlace($widget, BOL_ComponentAdminService::PLACE_DASHBOARD);
//$cmpService->addWidgetToPlace($widget, BOL_ComponentAdminService::PLACE_PROFILE);

The "//" in front of the last two lines disable these locations. If you remove the "//" these should become available. Just remember. Any time you make changes in cpanel you need to set Dev Mode to true "ow_includes/config.php", and go to your site, and refresh the page. Then set Dev Mode back to false. Just an additional note. Anytime the plugin is updated it will be changed back to the original settings.
Ulises Aguilera
Ulises Aguilera Oct 25 '15
This is amazing. Thanks.
Do you know where can I change and what lines do I most to change in the Dev Mode?.

I really apreciate your help, A thousna thanks.

Darryl B Leader
Darryl B Oct 26 '15
When you open the config.php file. Scroll to the bottom. You will see three lines with a setting of "false" You will see that one of those is Dev Mode. Change the false to true, save the changes, go to your site, refresh any page, set dev mode back to false, and save the changes.
Glen Williamson
Glen Williamson Dec 1 '15
I did the above (removed the //), debug, refresh and still don't see the Slideshow in the user dashboard.  What am I doing wrong?

Thanks in advance.

Running Oxwall/Skadate 1.8.0

The Forum post is edited by Glen Williamson Dec 1 '15
Darryl B Leader
Darryl B Dec 1 '15
You mentioned "debug". debug isn't the one you set to true. It is "Dev Mode". Once you set this to true, and refresh your site, then set it back to false. You would need to go to your admin panel to add the slideshow to the user dashboard. It should show as an available widget there. I just tried it. You will also need to deactivate the slideshow plugin, and then reactivate it. Then it will show.
Glen Williamson
Glen Williamson Dec 1 '15
Hello Daryl,

Thanks for writing back.  I meant "Dev Mode". 

The solution for me was to deactivate Slide Show and reactivate it again. 

Thanks for the solution.