We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Group upgrade rendering admin section useless | Forum

John Thomas
John Thomas Mar 1 '12

Indicator on admin panel that update for Groups was available.  Backed up db and clicked upgrade.  Now when I go to admin section the following is displayed.

Platform update requestThe source code of 'Groups' plugin was updated. Need to update plugin DB.

I click on Update which displays a 404 url with

Page not found

displayed.  Unable to get out of loop.  Tried removing group plugin, disabling in Db neither works.  

Put site in debug mode 

    define('OW_DEBUG_MODE', true);    define('OW_DEV_MODE', true);

but no data indicating what the error may be.

At a loss how to correct.  Please help!  Unable to administer site.

Michael I.
Michael I. Mar 8 '12
Do you have default .htaccess file content or is is modified?
John Thomas
John Thomas Mar 8 '12

Hello, thank you for your reply.

It was modified.  

# For security reasons, Option followsymlinks cannot be overridden.

#Options +FollowSymLinks

Options +SymLinksIfOwnerMatch

RewriteEngine On

AddEncoding gzip .gz

AddEncoding gzip .gzip

<FilesMatch "\.(js.gz|js.gzip)$">

  ForceType text/javascript


<FilesMatch "\.(css.gz|css.gzip)$">

  ForceType text/css


RewriteCond %{REQUEST_URI} .*/http-bind

RewriteRule (.*) /http-bind [L]

RewriteCond %{REQUEST_URI} !^/child_folder/

RewriteCond %{HTTP_HOST} ^odbc\.[ Domain ]\.com$ [OR]

RewriteCond %{HTTP_HOST} ^www\.odbc\.[Domain]\.com$

RewriteCond %{REQUEST_URI} !^/index\.php

RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]

RewriteRule (.*) index.php

- - - -Plus a list of IP blocks that are blocked to prevent my site from getting hacked again.

The Forum post is edited by John Thomas Mar 8 '12
Ilearning Mar 9 '12
I have experienced a similar problem, i upgraded from 1.3 to 1.3.1 and update all the plugins, but the group plugin still did not display the new features, so i downloaded from Oxwall site Groups   http://www.oxwall.org/store/item/36  and re-installed  it, after which i encountered site error, where by i cannot even access my root now. please advice. 
John Thomas
John Thomas Mar 9 '12
I tried just about everything with no success.

Fortunately, I had a backup of the site directory prior to trying to upgrade the Groups plugin.  I replaced the existing site with the backup.

This got me to where I could at least administer the site.  Then I uninstalled the Group plugin.

I made sure I had backups of EVERYTHING, before I tried this.  I'm happy to report that everything is functional as expected now.  (sans the Group plugin which I will not re-install)

Good Luck!