We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

V. 1.7.4. forum search error | Forum

Ilja Jun 3 '15
Hi guys, 

trying to find something in forum I get the error message.

The same error is in this forum :). So easy to reproduce:  http://www.oxwall.org/forum/search?&q=forum

Message:SQLSTATE[42000]: Syntax error or access violation: 1305 FUNCTION oxwallo_deploy.FIELD does not existFile:/home/oxwallo/public_html/ow_core/database.phpLine:707Trace:#0 /home/oxwallo/public_html/ow_core/database.php(707): PDOStatement->execute() #1 /home/oxwallo/public_html/ow_core/database.php(398): OW_Database->execute('????SELECT `t`....', NULL) #2 /home/oxwallo/public_html/ow_plugins/forum/bol/topic_dao.php(309): OW_Database->queryForList('????SELECT `t`....') #3 /home/oxwallo/public_html/ow_plugins/forum/bol/forum_service.php(1425): FORUM_BOL_TopicDao->findListByTopicIds(Array) #4 /home/oxwallo/public_html/ow_plugins/forum/bol/forum_service.php(1687): FORUM_BOL_ForumService->processFoundTopics(Array, 'forum field err...') #5 /home/oxwallo/public_html/ow_plugins/forum/controllers/search.php(397): FORUM_BOL_ForumService->findTopicsInGroup('forum field err...', 5, 1, NULL, NULL) #6 /home/oxwallo/public_html/ow_plugins/forum/controllers/search.php(115): FORUM_CTRL_Search->searchEntities(Array, 'group') #7 [internal function]: FORUM_CTRL_Search->inGroup(Array) #8 /home/oxwallo/public_html/ow_core/request_handler.php(266): call_user_func_array(Array, Array) #9 /home/oxwallo/public_html/ow_core/application.php(329): OW_RequestHandler->dispatch() #10 /home/oxwallo/public_html/index.php(73): OW_Application->handleRequest() #11 {main}Type:PDOException

dave Leader
dave Jun 3 '15
i do not have this issue myself at same url  

on my site 

Ilja Jun 3 '15
Dave :) Seems you have better setup than Oxwall guys :).
ross Team
ross Jun 4 '15
Thanks guys for the report, the issue been fixed. Seems like by the time Dave was doing the search the issue was fixed. 
dave Leader
dave Jun 4 '15
thats how i roll lmao... :) 
Ilja Jun 4 '15
Ross. Ok. :) looking forward for Forum plugin update, as on my setup it still does not work :)
ross Team
ross Jun 4 '15
If you have the same error you need to: 

go to the file forum/bol/post_dao.php

line 282

and replace




(it's removing space)

this should fix the issue. 

Ilja Jun 5 '15
Ross actually your fix is not very correct:

1. the line number is 252.

2. I had to do the same in file topic_dao.php: line 309

ross Team
ross Jun 8 '15
Sorry, you're right the line is 252 and in topic_dao.php file too.