We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

I can't get the url/install working | Forum

Niko G
Niko G Oct 26 '15



I’m trying to install Oxwall on an Amazon EC2 instance. I created security group and I have my dynamic IP.

I have launched my Ubuntu 14.04 as well as installing Linux, Apache 2.4.7, Php 5.5.9 and MySql 5.5.4.

I downloaded Oxwall 1.8.0 via wget and unzip it though taskel.

But I can’t get the installation process by entering url/install in my browser.


I have checked that mod rewrite  is enable and that mod security is deactivated (it’s not installed, I find it nowhere)

Curl and url_f_open are enabled and register global is off; safe_mode doesn’t exist since php 5.4 and I can’t find anything and SUapache, suPHP and suhosin.

I have checked that GD library is installed and I have installed Exim as a mail server. I understood that cron should be activated after the installation.


I have a problem because I played too much with my directories in the conf files, if you go to it’s forbidden access, but you can check my php info here :

The oxwall files are uziped in 2 folder /var/www and var/www/html, I had for a moment the root of my server pointing to /var/www because I could see my own Welcome index.html but I could still not get the url.


I’m not 100% sure is all the options are enable/disabled correctly but I spend quite some time to check.

Could it be because I didn’t transfer through ftp? Or something wrong with htaccess ?


I hope someone can help, I have already had hard time setting the LAMP stack.


Kind Regards to all the community,



Tecca Oct 26 '15
Hmm, it's hard to say. It seems like it would be a misconfiguration on the LAMP stack, probably Apache. I managed to get Oxwall installed on a LEMP stack with no issues using SSH.

What are your global settings for Apache looking like? It should be something like httpd.conf.

Also, check to make sure that Apache processes have read/write capabilities on the correct folders.

ross Team
ross Oct 26 '15 also says forbidden 403, for some reason mod_security is blocking this url, please disable mod_security on your server or configure it properly. 
Niko G
Niko G Oct 31 '15

Thank you for you reply, 

It tooks me a bit of time but I have created a new conf file and I don't have the 403 error on my pages, I have a classical 404, I have really searched and I can't see anywhere that mod_security is activated.

Any suggestion to unlock the situation?

Thank you in advance


SongPhi Oct 31 '15
Hi Niko G,

The 404 page happen is probably because of rewrite mode is not yet turn on.

Did you tried "a2enmod rewrite" yet?

Hope this would help. If it's not this, I don't know what else.

Niko G
Niko G Nov 1 '15

Thank you for your answers,

I managed to get the install by going to the index.php.

But, I don't have any image displaying, I checked that GD library is installed, does there is something else I'm missing? 

Thank you in advance,

Best Regards,


ross Team
ross Nov 1 '15
Remove index.php at the end of your domain name from config.php file, it should be without index.php
Niko G
Niko G Nov 2 '15

I see several config.php files, and I don't want to make mistake, 

Which one are you talking about?

Also, could you be more precise on the location of the index.php I should remove?

If you go to  there is no /index.php at the end of the address and the home page is displayed (but without any grafics nor CSS).

Thank you for your support,

Best Regards,


ross Team
ross Nov 2 '15
ow_includes/config.php file it has a line HOME_URI I believe you have there

it should be without index.php just

please check. 

Niko G
Niko G Nov 3 '15
OMG Yes, it's working !

Thank you the graphics have appeared but now, I can't access the admin space anymore nor that I can't see any other page like /users and the rest, 

What do I need to configure now?

Thank you in advance,

Kind regards,


ross Team
ross Nov 3 '15
Niko, you either don't have mod_rewrite properly configured or you don't have default .htaccess file in the root of the software. Also check whether the .htaccess file has default content. 
Niko G
Niko G Nov 3 '15
Hi Ross,

mod_rewrite clearly appears in the Loaded Modules section of my php info.

In the root of Oxwall I do find a .htaccess,  please find in the attachement a screenshot of what it looks like.

Could  you tell me if some part is missing?

Thank you in advance,


Niko G
Niko G Nov 4 '15
I have also tried to remove the index\.php from the htaccess but it doesn't change anything...

Any idea what is going on? Do I need to do something to make the link working?

Best Regards,

Niko G
Niko G Nov 6 '15

Could I have an answer or at least a clue?

Do you need anymore information from me?

When I installed I couldn't see the graphics, but I could access the different pages.

Now I removed the /index.php in my config file and I have the graphic but I cannot start to develop my plateform,

Please help,

Best Regards,

ross Team
ross Nov 6 '15
Niko, the only thing we can think of is that your mod_rewrite is not properly configured as it contradicts with the rules specified in the .htaccess file
ross Team
ross Nov 6 '15
Also, even though mod_rewrite module is loaded, please make sure it is enabled. 
Niko G
Niko G Nov 8 '15

I managed to configure correctly my site my following what Scott add in his conf file there :


I can access all the page of my site now,


ross Team
ross Nov 8 '15
Great, thanks for letting us know. 
Niko G
Niko G Nov 16 '15
Hi again, 

During the instalation I didn't click on Forum, Image and Video,

How can I enable that afterward? 

Thank you in advance for your answer,

Best Regards,

  config oxwall 01.PNG (42Kb)
ross Team
ross Nov 16 '15
If the plugins are not here, in available plugins sectin: www.site.com/admin/plugins/available

then you need to download them directly from the store and install: https://docs.oxwall.org/install:plugin

Pages: 1 2 »