We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Installed update to 1.8.3 Now I'm hosed | Forum

Amy
Amy Jun 19 '16
I am getting Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /path to installation/ow_core/developer_tools.php on line 376


Apache Version2.4.16PHP Version5.5.36MySQL Version5.6.29


Tried a reinstall and that didn't work, either.


Now what?

dave
dave Jun 19 '16
Well Amy lets see if we can dehose you...   sorry your having issues.  I am surprised you are getting that error with running php 5.5.   Are you sure that is your version, how did you check the version?
ross Team
ross Jun 19 '16
Amy, please check your php version via phpinfo to make sure that you really have 5.5 php version
Amy
Amy Jun 21 '16
It wasn't, even though that's what was listed as running. I upped the version and put the old config.php back and the site came back.

Is there any way of putting in the update notification that server requirements have changed and should be reviewed?

Also, I have to update through softaculous. Oxwall doesn't update for me within the installation.
ross Team
ross Jun 22 '16
One request per topic please. 

Thanks for letting us know that the issue is resolved.