We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

404 while .htaccess enabled, mod_rewrite is on | Forum

Jayme Jun 29 '12

I've got a fresh 1.4.0 installation here:  http://jaymehunt.com/trades

Currently, the .htaccess file is renamed to x.htaccess so the index.php file loads up.  However, when I do enable it (it's the standard one that installed, no alterations at all), I get a 404 error for the whole site.

After going through the forums, I've checked with my hosting company to ensure compliance with server settings (see attached pdf file for *all* settings, as provided to me from my host).  Mod_rewrite is enabled; I had them check that particular setting specifically just moments ago.

I am a newbie to Oxwall, I'll admit, but I'm familiar with Oracle and databases.  PHP is not something I'm real great at, but I can step through what's going on with a road map.  There doesn't seem to be one of those for Oxwall, even with all the great help on the forums!  Perhaps I'll create one as I learn.

Update:  I did just try to add RewriteBase /to the .htaccess file and still get the same problem.  Whenever I go out to my site with .htaccess enabled, I get redirected here: http://redirect.main-hosting.com/error404.php/7

Update2: I've tried logging in as admin (the only user) and the site just spins.

Thanks for any assistance!


The Forum post is edited by Jayme Jun 29 '12
  host settings.pdf (360.68Kb)
Blaine Jun 29 '12
i have almost the same problem with still no solutions
Jayme Jun 30 '12

No one has any ideas on this??

Michael I.
Michael I. Jul 1 '12
Jayme, PM me your FTP, phpMyAdmin and Admin Area access details and we'll check into your request with our developers.
Jayme Jul 1 '12
Fantastic!  Thank you!
Jayme Jul 3 '12
Any news on this front?  I have about 70 families ready to trade art with each other as soon as there's a solution!  :)


The Forum post is edited by Jayme Jul 3 '12