We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Main link click produces 404 - file not found | Forum

Bill Brachhold
Bill Brachhold Sep 7 '16
I am trying to find social networking software for a small, local non-profit club, of about 75 members. Basically, site needs to support Groups, Photos, and Photo Comments.  Oxwall matches this very well.

All other links, 'Join', 'Members', 'Photo', and 'Video' work w/o issue. That seems to imply that in is not an Apache Rewrite mod issue.  Only the 'Main' link produces the error shown below.  Most people have problems with their .htaccess, this one is the one that came in the 1.8.4 ZIP file.

This is running on a private local server, running Debian Wheezy (7).

Any ideas ??

Thanks in advance !!
See attached images...
The Forum post is edited by Bill Brachhold Sep 7 '16
Attachments:
  mods.jpg (51Kb)
  config.jpg (15Kb)
  error.jpg (11Kb)
  php.jpg (19Kb)
Bill Brachhold
Bill Brachhold Sep 7 '16
Other thoughts ..

1. Ultimately, this will end up on a hosted server. I've not tried that yet, as I have fine tuning to do, mainly graphics changes.

2. Can I drop a debug into the router, or other core module, to try to see if the file name is being properly formed.  If YES, which file and which function ??

Thanks,

Bill
ross Team
ross Sep 8 '16
404 error means that there's something wrong with rewriting. 

Even though the module is loaded, it does not mean it is enabled or properly configured. 


Do you have default .htaccess file in the root of the software? Does it have default content? 

Bill Brachhold
Bill Brachhold Sep 8 '16
Yes, there is another .htacces file, back in the httdocs root. Very little in it, except code to block all incoming requests, except for specific addresses.

Root .htaccess file
---------------------
order deny,allow
deny from all

# home
allow from 192.168.0.1/24

(Note that there are several of these blocks, like this one)
# some address in the wild
allow from 173.zz.xxx.yyy

# some other address in the wild
allow from 154.xx.yyy.zz
.
.
.
------------------------------

As I said above, ultimately this will end up on a hosted server. But it CANNOT be located in the root folder, because that hosted server has many sub-websites.

Again, thanks for any help I can get !!
Bill
The Forum post is edited by Bill Brachhold Sep 8 '16
ross Team
ross Sep 8 '16
You need to make sure you have default .htaccess file IN THE ROOT OF THE FOLDER WHERE SOFTWARE IS INSTALLED, not root of your htdocs folder. 


Do you have .htaccess file there? 

Bill Brachhold
Bill Brachhold Sep 8 '16
Yes, the .htaccess I posted in the original post, is located in the oxwall folder. Again, this is the .htaccess file that was in the oxwall_1.8.4.zip file that was downloaded from the Oxwall main site.

Here it is again, for clarity:

Options +FollowSymLinks
RewriteEngine On

AddEncoding gzip .gz
AddEncoding gzip .gzip
<FilesMatch "\.(js.gz|js.gzip)$">
  ForceType text/javascript
</FilesMatch>
<FilesMatch "\.(css.gz|css.gzip)$">
  ForceType text/css
</FilesMatch>

RewriteCond %{REQUEST_URI} !^/index\.php
RewriteCond %{REQUEST_URI} !/ow_updates/index\.php
RewriteCond %{REQUEST_URI} !/ow_updates/
RewriteCond %{REQUEST_URI} !/ow_cron/run\.php
RewriteCond %{REQUEST_URI} !/e500\.php
RewriteCond %{REQUEST_URI} !/captcha\.php
#RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]
RewriteCond %{REQUEST_FILENAME} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
The Forum post is edited by Bill Brachhold Sep 8 '16
Chris_W
Chris_W Sep 8 '16
When you hover your cursor over the link that 404s, what is the url displayed in the browser task bar? Is it correct?
Bill Brachhold
Bill Brachhold Sep 8 '16
Main link - 192.168.0.15/oxwall/index

And these 4 work without issue. That seems to imply that mod_rewrite is working

Join link - 192.168.0.15/oxwall/join
Members link -192.168.0.15/oxwall/users
Photo link - 192.168.0.15/oxwall/photo/viewlist/latest
Video link -192.168.0.15/oxwall/video
ross Team
ross Sep 9 '16
Can you rename htdocs .htaccess file to something else and see if the issue persists with the main menu link? 
Bill Brachhold
Bill Brachhold Sep 9 '16
I renamed the httdocs .htaccess file to .htaccess.old, same result.  Had to change my "/etc/apache2/sites-available/default" file from 'deny from all" to "allow from all", so I did not get a "Forbidden" page-message.

But, exactly the same result, all top links work except 'Main'.  When I first go to the "/var/www/oxwall" folder with the browser, I see a "Page Not Found" message about 1/2 down the oxwall page that is showing.

At this point, I'm probably not going to be able to use Oxwall, so lets not worry about resolving this issue. Take this thread as a possible bug report, or maybe something weird about server configuration.

Thanks for all the help too !!

Bill

ross Team
ross Sep 9 '16

Let's not give up so easy. 


Let's try a couple of other solutions. 


Try to add this line 



RewriteBase /oxwall/


to oxwall .htaccess file right after “RewriteEngine On” line


also try to rename oxwall .htaccess and see whether you can open index page, all other links should be 404


if index page does not open in this case, there's something wrong with the mod_rewrite configuration. 

Bill Brachhold
Bill Brachhold Sep 9 '16
Hi Ross,

OK, adding 'RewriteBase /oxwall/' in the position you suggested, made no difference.

Renaming the .httacces file to something else, DOES allow 'index.php' to load and the theme displays, but down in the middle of the page, I see this: "Page not found Sorry, this document doesn't exist."


Now, on the 4 other links, I'm seeing the error message I originally posted, 404 error, directly out of Apache.

I will investigate Apache's mod_rewrite module, and try to figure out a way to test it.

Off to mow the yard ....

Thanks,

Bill


The Forum post is edited by Bill Brachhold Sep 9 '16
Bill Brachhold
Bill Brachhold Sep 11 '16
Ross and others ...

[SOLVED]

Had to change the first line of Oxwall's default '.htaccess' file.

from: Options +FollowSymLinks
to: Options +FollowSymLinks -MultiViews

Thanks for all your help.

Bill
ross Team
ross Sep 12 '16
Great, thanks for letting us know.