We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

I have got 3 issues on my hand. | Forum

Ibraheem Sep 20 '12
Hi. I have three issues on my hand:

1: Google Connect won't work. I get the following message:

The redirect URI in the request: http://www.woodlandsmsa.com/google/oauth did not match a registered redirect URI

However, In the app, as stated this is info I have entered:

Redirect URIs:http://www.oxwall.org/google/oauthJavaScript origins:http://www.oxwall.org

So I don't know why its not working :(




2: Facebook Connect isn`t working for some reason. I have attached the error picture... Help.


3: You know how at the top bar, it says: Chat. I would like to move that to the bottom if possible :)


I have searched them but I couldn`t find anything.

  facebook-error.png (14.84Kb)
Alia Team
Alia Sep 21 '12
Ibraheem, seems like you have followed instructions given in our manual literally. In our manual oxwall.org  URL was used just as an example. When you set your Google and Facebook connect use your own URL and not oxwall.org.

With regards to "Chat", can you elaborate more on which chat you mean. Screen shot pointing it out would be very helpful.

Ibraheem Sep 21 '12
Okay I have got the Google Issue sorted out :)

You were correct, I just need to do that thing...


However, For the facebook connect, I still get the same error. I mean, I have done the following things in Facebook app:

I have entered the App ID:

I have entered the App Secret:

My App domain is set to: woodlandsmsa.com

Category: Entertainment.

Sand Box Mode: Enabled

Site URL: http://www.woodlandsmsa.com/

Canvas URL: http://woodlandsmsa.com/contactimporter/fbcanvas/

For Permissions, I have set it to public.

Could it be the fact that my domain is hosted under my primary domain which is: techdevelopersguide.com. However, I created two directories, one naming: techdevelopersguide and the other naming woodlandsmsa and then redirecting the website woodlandsmsa.com to that woodlandsmsa directory. Add on domain.

So in public_html I see two folders: techdevelopersguide & woodlandsmsa


For the chat, I have attached the the screen shot, please feel free to look at it :)

  chat.png (22.12Kb)
Alia Team
Alia Sep 24 '12

2. Facebook app issue. Can you give us screen shots of your  Facebook application (how you set it up) ?

3. Chat. You will need to submit a new topic here http://www.oxwall.org/forum/8 . Try searching the forum first. Somebody else might have had the same question before and the answer might already be there.

Ibraheem Sep 26 '12
Alright, I have attached two pictures.

The first picture name: fb set up: it show how my Facebook application is set up.

I have it set up. I even got the confirmation message which I have attached with the name: fb-oxwall-set-up.

You can take a look at both of them...the message still appears...


As for the chatbar, I just installed arrowchat and disabled the ChatIM. That one is solved. Just the Facebook issue is left.

The Forum post is edited by Ibraheem Sep 26 '12
  fb set up....png (43.37Kb)
  fb-oxwall-setup.png (65.19Kb)
Alia Team
Alia Sep 28 '12
Ibraheem, check my screen shot. Make sure you set your Facebook app in the same way. Do not edit anything in "App on Facebook" section.
Ibraheem Sep 28 '12
Dear Aliia, You Literally rock! ILY <3


Thanks, its fixed now :]

Alia Team
Alia Sep 30 '12
Thank you ;)