We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

/install is not found when using https | Forum

Topic location: Forum home » Support » General Questions
mahmood Sep 5 '18


I am trying to setup a local social network that has been developed by Oxwall. So, the question may not be an Oxwall issue, but I appreciate any feedback because I have stuck at the problem!

have configured a Centos server with httpd for ssl support. Prior to that when I entered http://w.x.y.z I was able to see in the install page. After configuring ssl, I removed all files from /var/www/html and was able to see the test page when entering https://somewhere.com

Now when I put website files in /var/www/html and enter https://somewhere.com, I get this error


Therequested URL /install/install.php was not found on this server.

It seems that .htaccess file is incomplete for https access. However, I don't know what rules should I add. I also searched for similar things but didn't find a clear answer.

The content of the virtualhost is

[root@localhost html]#cat /etc/httpd/sites-available/moto.conf







     Options FollowSymLinks

     AllowOverride All


      allow fromall

      Require all granted





and the content of .htaccess is

Options +FollowSymLinks

RewriteEngine On

AddEncoding gzip .gz

AddEncoding gzip .gzip

<FilesMatch "\.(js.gz|js.gzip)$">

  ForceType text/javascript


<FilesMatch "\.(css.gz|css.gzip)$">

  ForceType text/css


<Files CHANGELOG.txt>

deny from all


<Files INSTALL.txt>

deny from all


<Files UPDATE.txt>

deny from all


RewriteCond %{REQUEST_URI} !^/index\.php

RewriteCond %{REQUEST_URI} !/ow_updates/index\.php

RewriteCond %{REQUEST_URI} !/ow_updates/classes

RewriteCond %{REQUEST_URI} !/ow_cron/run\.php

RewriteCond %{REQUEST_URI} !/ow_cron/run\.php

RewriteCond %{REQUEST_URI} !/e500\.php

RewriteCond %{REQUEST_URI} !/captcha\.php

#RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]

RewriteCond %{REQUEST_FILENAME} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]

RewriteRule (.*) index.php

Any thought?

The Forum post is edited by mahmood Sep 5 '18
dave Leader
dave Sep 10 '18
did you change your ow_includes/config.php file url to https