We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

View More Button not working! | Forum

Klaus Rock
Klaus Rock May 4 '19

View More Button not working


Version 1.8.4

PHP 7.2.17


Any Idea ??


Thanks


Patricia Zorrilla Leader
Patricia Zorrilla May 4 '19

There are many plugins that do not go well with PHP higher than 7.0. Errors do not give, they just do not work well, like the photo plugin.

It is better to ask your server to enable PHP 7.0 or better yet, to enable you to change it yourself.

With 7.0 and 7.1, this plugin works perfectly, with 7.2 I have not tried it.

Klaus Rock
Klaus Rock May 7 '19

Hi Patricia,


I tried 7.1.28 and a PHP Execution Time of 30 s but still not working.

7.2.17 is working well except this View More Problem.


Seems to be an incompatible PHP Script Problem.


Does the Oxwall Team still work or did they already surrender?


Thanks for your answer.


Klaus



Chris_W
Chris_W May 7 '19
Apart from Oxwall Germay we haven't seen any of the team on here for years.


If you can't find a fix, try this free plugin.

https://developers.oxwall.com/store/item/800

Klaus Rock
Klaus Rock May 8 '19

Thank you Chris,


Not working with 1.8.4


Klaus

Chris_W
Chris_W May 8 '19
I have moved my sites over to this Oxwall fork, so far I haven't had a single problem. https://developers.oxwall.com/forum/topic/64076?&page=1
Quote from Klaus Rock

Thank you Chris,


Not working with 1.8.4


Klaus


The Forum post is edited by Chris_W May 8 '19
Patricia Zorrilla Leader
Patricia Zorrilla May 8 '19
Works perfectly with OxWall in all versions !!!And with all the subjects that I have tried.You can see it working here with OxWall 1.84 and PHP 7.0 without registering or anything

https://somoscd.es/testsite/index

https://somoscd.es/testsite/dashboard


Quote from Klaus Rock

Thank you Chris,


Not working with 1.8.4


Klaus


The Forum post is edited by Patricia Zorrilla May 8 '19
Oxwall Türkiye
Oxwall Türkiye May 8 '19

The add-on you're talking about is running the problem from elsewhere.

Please submit your error log.

Undo the most recent changes.

3. Cancel the installation for the problem caused by the party plugin.

Check your PHP version

Check your PHP permissions

Check your server mod_sec status.


Please send your log as PM for further assistance.


No more showing plugins are running smoothly, the problem should be caused by server or permissions. If you make any changes, you may see a problem. For further assistance, please report on the forum site and report the result. Try searching for a topic in the forum topic. If the result is not found, I can try to help you if you send your log record to PM communication.

Klaus Rock
Klaus Rock Aug 2 '19

All Files and Directory Permissions are set correctly.

mod_sec Status ok.

PHP Version ok.


But still these huge warnings and errors.


[Tue Jun 18 06:36:25.263910 2019] [fcgid:warn] [pid 5870] [client 175.44.18.68:47846] mod_fcgid: stderr: PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Securimage has a deprecated constructor in /var/www/vhosts/tennis-motion-connect.com/httpdocs/ow_libraries/securimage/securimage.php on line 95, referer: http://www.tennis-motion-connect.com/...ft=user&fi=13101

dave Leader
dave Aug 3 '19
Yeah that is a warning letting you know that changes are going to happen.  I suspect since you are using php 7+  is the reason for the warning.   
The Forum post is edited by dave Aug 3 '19
AppXprt
AppXprt Aug 3 '19

PHP 7 Deprecation...

Secureimage library needs to be updated... I could add this to OxUpdater for auto updating, but probably won't since this place is essentially dead.
The Forum post is edited by AppXprt Aug 3 '19
Oxwall Türkiye
Oxwall Türkiye Aug 4 '19

Friends I am not getting such errors when I am using PHP 7+ version. My site is a live continuous site. I know there are jobs that need updating in the last year. However, most of the errors received for oxwall consist of server settings.


A lot of developers are adding products and it doesn't help when we think about their work. Oxwall's fine.


In addition, you should know, there are many structures bifurcated on the oxwall github. A few of them are constantly updated, you can get your updates in them.