We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

FTP problem | Forum

Gagan Jan 24 '13
Insatlled AMPPS and OXwall in it am trying to make my system a server

now when i tried to dataimport everything went fine but now on the FTP section i says user doesnt have the permission to overwrite...

i Dont know what to put in FTP section....

please help me an new to this...

  1-25-2013 7-54-36 AM.jpg (95.19Kb)
Gagan Jan 24 '13
what nobodys here..?anybody relpy...???
Ronnel DC
Ronnel DC Jan 25 '13
this is the most common problem for oxwall users, sorry
Gagan Jan 25 '13
So..?Tell me What to Do..? 
cit27 Jan 25 '13
Have you checked the files permissions for that user
Gagan Jan 25 '13
how to change the file permission..?
Stuart Jan 26 '13
Has anyone checked there ftp log.

I am not getting an authentication error is I check the log even though oxwall reports it as such.

For some reason I am getting a duplication of the the root folder of the oxwall install.

I am on ubuntu with vsftp and oxwall thinks its is installed in /var/www/var/www

Which it isn't as it should be just /var/www and the above doesn't exist.

The actual error in my ftp log is that it can't create the test directory but authentication worked.

The Forum post is edited by Stuart Jan 26 '13
Stuart Jan 27 '13
Mmmm Not many replies on this one. Devs would you send me some details of where the code is that returns the root Dir?

I will have a go at a clumsy hack as it might just be me and my server setup (zentyal)

Alia Team
Alia Jan 29 '13
Gagan, can you PM me FTP/admin access details ? Thank you.
Purusothaman Ramanujam
I did some analysis on the code and I guess I found out of the issue for most FTP related issues.

I need someone to help me on this to confirm my findings.
Stuart Jan 29 '13
Puru, pm me and I will try any changes.
Purusothaman Ramanujam
Have sent PM.
Stuart Jan 30 '13
Can anybody else send there ftp log. Not what oxwall reports but the ftp log of there server?

Tue Jan 29 22:52:21 2013 [pid 2] CONNECT: Client ""

Tue Jan 29 22:52:21 2013 [pid 1] [ftp-user] OK LOGIN: Client ""

Tue Jan 29 22:52:21 2013 [pid 3] [ftp-user] FAIL MKDIR: Client "", "/var/www/var/www/ow_core/test"

this is from vsftp.log on ubuntu with vsftp

Michael I.
Michael I. Jan 30 '13
Is that root user you work with?
Stuart Jan 30 '13
No its the owner of the the oxwall root, group is www-data.

ubuntu doesn't usually allow root through shadow passwords and sudo.

I just don't understand where oxwall gets that directory from as it doesn't exist.

It should be trying to create a directory /var/www/ow_core/test

where oxwall gets /var/www/var/www from I am unsure but it doesn't exist.

The oxwall root folder is /var/www

The Forum post is edited by Stuart Jan 30 '13
Gagan Jan 31 '13
will somebody reply to my prob What the ... i am pm ing everybody and nobody replying What kind of Support is This..???

Stuart Jan 31 '13
Its a while since I used ampps what ftp server is used? With hosting it depends on the hosting supplier and how you have also set up your control panel.

Its not really an oxwall thing to how and what user is setup. You will have to consult your hosting provider for those details.

That is my experience gagan I have a server of my own and self host on a static IP so I am bit rusty and can't offer you more.

Gagan Jan 31 '13
look i am doing a localhost and filezilla is the ftp interface and if i had to login into the ftp server via ftp client i use the same details am using to login into oxwall server or local ip and it works but not on the address...
Stuart Jan 31 '13
It should work if you are local should work. Dunno. Have you checked your FTP log as does it state an authentication error or like I posted is it trying to create a directory in a directory structure that doesn't exist.

Authentication works on my server but the next line is a directory creation error. That is why I posted the above.

For some reason oxwall reports an authentication error but it isn't. I know why as a test it creates a dummy directory. But it isn't actually an auth error but as said directory creation error.

Stuart Feb 1 '13
Sorry for the bump!

Has anyone got any details of there ftp server log when oxwall tries ftp?

I am just interested, if you have an ftp error what does your ftp server say the error is?

I am sure this might bring some light to the scenario.

Anybody else with FTP errors would you post your log? 

Pages: 1 2 »