We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Can't upload avatars! | Forum

Liz Hall
Liz Hall Jan 29 '13
I am just starting using the Oxwall software for a new ski club site I am putting together.  Everything is working great, except I can't upload any photos or avatars.  Whenever I try to upload the photo, it loads for awhile then there's a popup that says "Please choose image file".  I have updated everything and it is still not working.  Does anyone know how to fix this?
  avatar.jpg (239.08Kb)
Emerson Jan 29 '13

Hello I'm having the same peoblema I would like to know how to solve.


Alia Team
Alia Jan 30 '13
Make sure that following folders exist on your server:
-folder "avatars" under /ow_userfiles/plugins/base/
- folder  "avatars" under /ow_pluginfiles/base/
- folder "photos" under  ow_userfiles/plugins/photos

Make sure that folders listed above and one folder listed bellow are set to have 777 permissions:


Emerson Jan 30 '13

Solve this problems seems that the file was missing in the folders, the solution I found was instlat by http://installatron.com/oxwall if you can I would like to know if there is another solution.

Thanks for Attention

Alia Team
Alia Jan 30 '13
If the file is missing, the solution is just to create missing file. In this case, create missing folder.
Liz Hall
Liz Hall Jan 30 '13
Thanks for the response, and it kind of worked.  Now after uploading a photo, it shows the crop photo screen, but there is no photo there.  Any ideas?
Liz Hall
Liz Hall Jan 30 '13
Here's a shot of what it looks like
  photo_2.jpg (168.16Kb)
Liz Hall
Liz Hall Jan 30 '13
Problem fixed!  Instead of adding the folder "avatar" under /ow_userfiles/plugins/base/

I changed the folder name to "avatars", and it worked!

Thanks for all your help!
Alia Team
Alia Jan 31 '13
Liz, sorry. It was my mistake. Glad to hear everything is working now.
Corrected my first response in case somebody faces the same issue in future.
Jochen Sep 8 '19
Hi all, I have the following problem:
I upgraded from version 1.6 to the latest version 1.8.4 as follows:

I installed (completely new) the version 1.8.4, including the Core-Update.
Also after installing some plugins, everything was OK.

Then I imported all User-Files from the old version to the new version.
So I imported the following tables from version 1.6 to version 1.8.4


Then I copied all avatar-pictures to the new versions folder

So far so good,- all users are displayed including their profile, privacy-settings and avatar.
At the first login to the new version all users just had to request a new password.
Still all is OK and all plugins are running perfect.

The only thing that is NOT working anymore is : All users including the admin cannot change their avatar.
If I click on "change Avatar" and click to choose a file, I choose a file, I see that file, I click on "apply crop"  and right after I see the red bar with the text "Crop Avatar Failed". (see attached files).

If I try to change  my avatar via "Edit Profile Details" it is a little bit better, here most of the time the crop works and after click on "apply crop" I can directly see the small new User Photo but:  After click on "Save" the picture is not displayed, although the green top bar says "User Data Updated". During this, when I saw the small Userphoto I right-clicked it to see where this photo is stored -

the link is: ow_userfiles/plugins/base/avatars/tmp/avatar_5d74abb9d5412.jpg?1567929123173

Then I checked via FTP and saw that all avatars were saved in a subfolder of the avatar folder, the folder "tmp"   like in the above link.

Did I forget to import some tables ?
I already set all folder permissions to 777
In debug-mode no error is shown and also the error-log is empty.

Anyone an idea ?

Would be great, thanks in advance, Jochen
The Forum post is edited by Jochen Sep 19 '19
  crop-error3.JPG (33Kb)
  crop-error-en.JPG (71Kb)
  sourcecode-save-avatar.JPG (178Kb)
dave Leader
dave Sep 23 '19
Does the console show anything regarding a js error when you get the failed message?

Also look at this it might help as well.  


the link to the oxwall wiki on migration is also in that post. 

You probably should have just saved the secret key and put it back, that way users would not have to make new passwords, but whats done is done :) 

You migh also try deleting everything in your ow_smarty/template_c  folder   Dont worry oxwall will recreate it.   Even if you delete the template_c folder itself oxwall will recreate it.  

You might try that because it may be a file owner issue as well..  If your using cpanel there are times that cpanel on a migration using ftp does not set the correct file owner so for that see here.  Expecially if you might be changing how you serve up php files apache vrs some speed feature. 


Also verify that your server meets the requirements on the right side of this page, and specifically mod security.

The Forum post is edited by dave Sep 23 '19
Jochen Sep 24 '19

Hi Dave, thanks for your reply but today I fixed and solved it by myself.

Inside the database table  "ow_base_avatar"  the collumn  "status" was missing.

So I added this column, entered the value "active"   and everything is fine again.

Now Crop is working again and Profile Pictures can also be uploaded and saved as usually.

I hope this thread will help others to fix their Avatars / Profile Pictures Problems,

br, Jochen

dave Leader
dave Sep 24 '19
Thanks for sharing the fix and im glad you got it sorted.