We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Notification & Email - Email Notifications | Forum

jordan jovanov
jordan jovanov Apr 9 '13

I have installed this extension, but I didn't received emails. I want user to received Email notification no matter does he saw notification on web site.

With other word: If Some comment on my post can I immediately receive email notification

Alia Team
Alia May 17 '13
jordan jovanov, email notifications are sent only if user was not loged in when those notifications came.

>>but I didn't received emails.

1. Log in as your user>>my preferences>>email notificaitons>>set them to "Immediately"
2. Make sure that correct email is specified in admin panel>>settings>>main settings
3. Make sure that your Cron is running.
4. If you are using SMTP, make sure that it is configured properly as well.

Log out as you users from the site.
Log in as another one, and add your first user to friends or send him PM.
Wait until your Cron runs.
Check first user's email.
Sanjay Singh
Sanjay Singh Jun 19 '13
I noticed that if there is no entry in ow_notifications_schedule corresponding to the user accounts in ow_base_user, then no notifications are sent. So I had to manually enter the values for each user in the table by using the command as below:

insert into ow_notifications_schedule (userId, schedule) values (46, 'immediately');

Once these entries were made, all the user for whom update has taken place received email notifications. Actually, when user is created a corresponding entry should be made in this table (I think so), which is not happening in my case. And therefore no notifications.

I thought probably others also may be facing similar problem and case solve it by following this procedure, till oxwall comes out with a permanent solution to it. 

ross Team
ross Jun 26 '13
Have you checked your cron configurations and e-mail notification setting?
You do not have permission to reply this topic