We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Auto update of core does not work with Safari | Forum

Henrik Apr 25 '11
Auto update of core does not work for me. I get a message telling me that the core has been successfully updated, but the core functionality does not change, and updating plugins gives me a broken site.

Manual update works fine though, and this is how I have upgraded to both version 1.1.0 and 1.1.1. After updating the core manually, auto update of plugins works without any problems.

I update my site using Safari 5.0.5 on a MacBook Pro with Mac OS X 10.6.7.
Den Team
Den Apr 26 '11
Hello Henrik!
How did you check that core file didn't change after update? Also what error give your updated plugins?
Henrik Apr 26 '11
I didn't do any thourogh check on the core files, so I may be wrong on that part. Updating the plugins only work after a manual update of core though.

When using some of the updated plugins after auto update of core I got an error message saying that som constants or labels didn't exits or something like that.

I am sorry for the vague bug report. Please let me get back to you after the next upgrade. If you let me know what files that are supposed to change I can look at the files time stamps and see if they do. I can also write down the error massages and let you know what they are. Is there something else you would like me to include in the bug report?
Michael Leader
Michael Apr 27 '11
Always handy to check site functionality on a variety of platforms, IE, Firefox, Chrome etc. Not all users will use safari...

In the admin dashboard it tells you what platform version you are running...
Henrik Jul 30 '11
As usual, auto update does not work for me. After clicking the link for updating to version 1.2.1 and entering the ftp details I am directed to a page telling me that my site is up to date. However, in the admin area I can still read that the platform version is 1.1.1. The link for updating is also still there.
The Forum post is edited by Henrik Jul 30 '11
Den Team
Den Aug 1 '11
Would you send me your FTP/Admin details? Our dev team will check it.
Henrik Sep 19 '11
As usual, auto update does not work for me. I have decided not to wait any longer for your dev team to check it and to do a manual update instead.

The platform version of my site is now 1.2.2. Do I need to update to version 1.2.3 before updating to version 1.2.4, when doing the update manually?
Michael Leader
Michael Sep 19 '11
Henrik,  I am not even seeing an auto update notification.  I am too in a similar boat where I am at 1.2.2.

I wonder if this is related.
Den Team
Den Sep 20 '11
Send me PM with your FTP/Cpanel/Admin details. If you don't receive this auto update requests, then you have some hosting settings which block any updates checks.
Henrik Sep 20 '11
I do see the link for auto update, but clicking it does not update the core. I have sent you the details.
Henrik Oct 15 '11
Here is the latest update on a seemingly never ending story:

I have been using Oxwall since February 2011 and during that time, auto update of core has never worked for me. After clicking the update link in the admin area and entering my ftp-details, I am directed to a page telling me that my site is up to date. However, in the admin area, the platform version number does not change and the update link is still there.

Therefore, I have always updated my site manually. Most of the times, this has worked, eventhough I usually get some warning or error telling me that something is strange with the database. At one occasion I ended up with a slightly broken site, but managed to reinstall the software, using my old user files and database. After that it looked fine again.

I first thought this was a browser issue, hence the title of this thread, but the problem remains no matter what browser I use, so that is not the case.

The Oxwall development team looked at my site and proposed that PHP needed to be recompiled with zlib support. I talked to my web host Arvixe about it, but they insured me that PHP is correctly installed, up to date and include zlib support.

Today I have manually updated my sites core from platform version 1.2.2 to 1.2.4. There was once again an error message, this time telling me that there wasn't enough room in some array in the database. Still, my site seems to be okay.

Updating the core manually is not a problem for me. I doesn't take much time and it is a simple task for me to do. The error messages are worrying though and I fear that I eventually will end up with an irreversibly broken site.

In an attempt to address this problem have tried to export all user data with the data exporter, delete and reinstall the Oxwall software and then import the data using the data importer, but this fails in the last step with some error message that I don't understand.

I am starting to run out of ideas, other than deleting everything and starting over, but that is of course my last resort, especially since I don't know if that will work either.

Does anyone have any suggestions on how I should proceed?
The Forum post is edited by Henrik Oct 15 '11
Keelan Leader
Keelan Oct 15 '11
I have been playing with oxwall and testing all sorts of functions and i haven't even come close to something similar to you. 

A manual install just works it is one of the easiest processes i have come across.

Have you tried a fresh install of 1.2.4 on a subdirectory and still get the same issues? If not then try duplicated the database and add it too the new oxwall site. If all works fine replace your existing.

Auto update doesn't work for me either for plugins or core so i just manually do it and it works nicely.
The Forum post is edited by Keelan Oct 15 '11
Henrik Oct 15 '11
It's a relief to hear that I am not the only one with an auto update problem!

My site is now updated to version 1.2.4 and it seems to be okay. However, I do get error messages every time I update manually, leaving me with the feeling that my site will eventually break. 

Thanks for the suggestion! Is your idea that I should use my backup to go back to version 1.2.2, do a fresh install of 1.2.4, and then connect the newly installed site to the old 1.2.2-version of the database, hoping that this will fix any problems I might have with the database?
Keelan Leader
Keelan Oct 15 '11
No first off install a fresh install on a subdiretory, with a fresh database. 

If everything seems to work okay which is should.

Try duplicating your original sites database and add the duplicated database to the new install and see if you still get issues.

This will then determine whether it is your files or database.
Henrik Oct 15 '11
Okay, I see. And since the only time I am having problems is during the update process, I need to install a fresh 1.2.4, wait for the release of 1.2.5, and see if the update goes smoothly on the fresh install?
Keelan Leader
Keelan Oct 15 '11
Sure, though honestly my host has the auto install script and it currently is still 1.2.3 and i update the cores manually with 1.2.4 upgrade and i head over to http://mysite.com/ow_updates and i don't hit a hitch.
Den Team
Den Oct 17 '11
Hello Henrik.
I remember your issue. Our dev guy tested and checked auto update on your site during 4 hours. Technically the issue was with unpacking archive with new platform and plugin version. PHP function unpack just doesn't unpacking archive incorrectly with damaged files an folders. The same update script works well on other hosting install without any problems. That's why our dev team decided that the problem is with your zlib extension and it needs to be recompiled. Maybe you should try to change a hosting? It is really confused when every attempt of autoupdate is failed and manually update works with errors. So there must not be. We do our best here in dev camp to make auto update to work smoothly. But we can't do anything when PHP extension works incorrectly :(

Henrik Oct 17 '11
Thank you, Addenster, for a more precise description of your findings! I will discuss this with the Arvixe support. If they cannot help me, I will change web hosting.
Henrik Oct 29 '11
Arvixe recompiled PHP and auto update now works for me! Great joy! =)
Den Team
Den Oct 31 '11
Nice to hear that your site works well for now :)
Pages: 1 2 »