We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Installing 1.5.3 on my OWN server[Answered] | Forum

Martin Wikstrand
Martin Wikstrand May 10 '13
There seems to be a major error/omission in the 1.5.3 zip file, when extracting it into my webserver home directory /var/www/xyz i can NOT get into the setup by entering localhost/xyz/install all i get is "The requested URL /xyz/install was not found on this server." This is quite correct as there is no install.php file or install directory included in the zip file. If i instead enter localhost/xyz/ i get a redirect to a page that is also non existent ! "The requested URL /xyz/install/requirements was not found on this server." I have done a chmod -R 777 /var/www/xyz just to be sure but no luck !

Please advice
The Forum post is edited by ross Jan 6 '14
Martin Wikstrand
Martin Wikstrand May 14 '13
Checked that post !

1. Are you trying to install Oxwall locally or on server? 

Locally on my server :-) Ubuntu 12.04 LTS running LAMP !
2. If on server, can you make sure that your server meets our requirements listed here: http://www.oxwall.org/hosting  

The link http://www.oxwall.org/hosting leads to page not found.

3. Can you send a screen shot of the error? 

4.  Make sure that mod_rewrite is installed and set correctly on your server. 

? , not sure I understand this ?

But if you do a list on the file  (oxwall-1.5.3.zip) , you will find the install directory/file is missing !

Since I'm not the only one having this problems I suggest there is something wrong with you zip file, please check !

The Forum post is edited by Martin Wikstrand May 14 '13
  Screenshot from 2013-05-14 10:37:09.png (493.21Kb)
Anon Omous
Anon Omous Dec 30 '13
Same issue.

1. Are you trying to install Oxwall locally or on server?
Locally, Ubuntu Studio 12.10 & 13.04

2. If on server, can you make sure that your server meets our requirements listed here: http://www.oxwall.org/hosting
apache 2.2.22, PHP 5.4.9, mysql 5.5.34, mysqli, curl, perl, mcrypt, geoip, ffmpeg, imagick extensions in addition to what is listed there.

3. Can you send a screen shot of the error?

4.  Make sure that mod_rewrite is installed and set correctly on your server.
mod_rewrite enabled and checked. can you provide more verbose details for "correctly"?
ross Team
ross Jan 6 '14
Anon, can you try xampp instead of lamp, probably this could work. Also check your ow_includes/config.php URL line whether the path is correct. If not get back to us. We'll try to help you. 
Mike Hill
Mike Hill Jan 21 '14

I tried to install 1.6.0 but have similar problems, so I post to this thread although it's a different version, I get the feeling that the problems are the same. 

I'm on Ubuntu 12.04 (own server). The INSTALL.txt file have the following errors: 

Under 1b it says one should download with wget from http://www.oxwall.org/dl/ow_1.6.0.zip

Well, that results in an Amazon wrong key error message. So one has to download from your web page manually. 

Under 3) you say one should run http://www.mysite.com/install but there's no such file or directory. That URL will result in an error. 

However, it is possible to get to the install page under ow_install, and it's even possible to follow the installation steps to the end. However, when the installation is finished and you go to localhost it looks crazy. Just plain text, no graphics, missing links and a complete mess in general, no themes can be activated etc. 

What's wrong? 

I use Apache 2.2.22, PHP 5.3.10, MySQL 5.5.32. 

MySQL database goes through port 3306. 

All folders and files have been set to 777 with chmod recursively just to be sure there are no privilegie problems. 


The Forum post is edited by Mike Hill Jan 21 '14
ross Team
ross Jan 22 '14
Mike are you sure, your server meet our requirements?
Mike Hill
Mike Hill Jan 23 '14
Quote from ross Mike are you sure, your server meet our requirements?

EDIT: Awful formatting when I posted, the message was garbled. Anyway, it looks like suhosin is installed and active. Which kind of problems does it cause?


Apache 2 or higher (with mod_rewrite module)
  Apache 2.2.22 with mod_rewrite enabled: 
Loaded Modulescore mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_mime mod_negotiation mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_status
PHP 5.2.6 or higher
PHP Version 5.3.10-1ubuntu3.7
with:register_globals off ..........YESsafe_mode off ...........YESsuPHP off ............ NOT INSTALLED (and therefore off)suApache off  ...............NOT INSTALLED (and therefore off)suhosin off THIS IS INSTALLED: 
This server is protected with the Suhosin Patch 0.9.10
Copyright (c) 2006-2007 Hardened-PHP Project Copyright (c) 2007-2009 SektionEins GmbH
Is that the reason?
PHP modules:PDO............... INSTALLEDDOM ............. DOM/XML ENABLEDmbstring ............... ENABLEDzip................ENABLEDzlib...............ENABLEDftp.............. ENABLEDjson............. ENABLEDMySQL 5.0 or higher.......................... YES, version 5.5.32GD Library 2 with FreeType support..........YES version 2Mail server (SendMail, Exim or other).............. SENDMAIL installed but path to from not set.Cron......... YES
Is it suhosin that is the problem? How do I disable it temporary to try? In the php.ini file or anywhere else? 


The Forum post is edited by Mike Hill Jan 23 '14
Mike Hill
Mike Hill Jan 23 '14
I went through all requirements and the only thing that wasn't meeting the requirements was that suhosin should be off, so I disabled it (by setting suhosin.simulation = On in php.ini), rebooted Apache, deleted the database and deleted all files on disk and repeated the installation. But there wasn't any difference. 


Mike Hill
Mike Hill Jan 24 '14
When I install, I put Oxwall in a sub directory under public_html, as I have lots of other projects on my server and cannot put Oxwall in the root (.../public_html/). I assume lots of other developers have the same needs. I assume there's no problem installing into a sub folder below public_html, right? 

It resides under .../public_html/oxwall/ so I have http://localhost/oxwall/ as the start page. 

The Forum post is edited by Mike Hill Jan 24 '14
ross Team
ross Jan 26 '14
Yes, Mike, there should not be any problem with installing software in the subfolder, make sure ow_includes/config.php file has right URL in this line:  define('OW_URL_HOME', 'www.domain.com/subfolder');

Enabled suhosin can cause malfunctioning of the software as a whole or some of it's features. It varies from case to case. However while installing oxwall in the subfolder  .htaccess files of other scripts conflict with Oxwall and don't let it work properly

ross Team
ross Jan 26 '14
Do you still get pages loaded without any graphics?
Mike Hill
Mike Hill Jan 27 '14
Still not working. Is adding the line "suhosin.simulation = On", in php.ini, a sufficient way to disable suhosin? I couldn't find any settings for suhosin in php.ini. 

ross Team
ross Jan 27 '14
I'm sorry, but I don't know how to do that via php.ini please find info in the internet or find a server specialist to disable suhosin
Mike Hill
Mike Hill Jan 28 '14
Actually, setting "suhosin.simulation = On", in php.ini, should be enough. Then it isn't active but just logs. So there must be something else. 

Has anyone ever succeeded to install Oxwall manually, from scratch, on Linux? I mean, there are serious typos in the INSTALL.txt file (see above), so I guess there's something missing either from the installation instructions or from the list of requirements. 


Yevhen Aug 17 '15
Same problem. The requested URL /install was not found on this server.
ross Team
ross Aug 17 '15
Check if you have mod_rewrite module enabled on your server, check whether the .htaccess file is in the root of the software and has default content from the download package(not empty, please compare)
macallister Feb 20
That is a good write-up When i viewed on account of write about the item. Really it is what exactly I need to to discover trust with foreseeable future you might go on intended for giving a really fantastic write-up. vietnam e visum fra Filippinene
macallister Feb 27
Exceptional article, gone ahead of time along with added your blog. My spouse and i can’t delay you just read additional via anyone. Security Consultant in New York
macallister Mar 2
Pretty good post. I just stumbled upon your blog and wanted to say that I have really enjoyed reading your blog posts. Any way I'll be subscribing to your feed and I hope you post again soon. Big thanks for the useful info. Iron Works NYC
Pages: 1 2 3 »