We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

veryfication email. | Forum

Topic location: Forum home » Support » General Questions
arik May 10 '13
Verification emails is not delivered  to users.  What do i do? Please help me. PLEASE. PLEASE PLEASE
MarkieMark67 May 10 '13
Have you setup and verified your CRON is working?
arik May 11 '13
Hello. Thanks to your answer.

I don't know. I have the file to path www.mysite.com/public_html/ow_cron/run.php

And what do i do with it? Please tell me about.


MarkieMark67 May 11 '13
arik depending on your Hosting the settings can very. Checkout this link for some basic settings. If you still have problems let us know.


arik May 11 '13
Thanks again. I have already read this document.  But I cannot understand nothing. Couldn't you explain to me better.
MarkieMark67 May 11 '13
arik I'll try

1.    Log into your Host Cpanel.

2.    Select CRON option

3.Next you will see Add New Cron Job

4.   Setup up how you would like it to run, every min, every 5 mins, so on

5.   On Command Line enter your command.

Examples:  You might have to play with settings.

wget -q -O /dev/null http://www.yoursite.com/ow_cron/run.php

lynx http://www.yoursite.com/ow_cron/run.php

curl http://www.yoursite.com/ow_cron/run.php

/usr/local/bin/php /home/site/public_html/ow_cron/run.php

5.    And save.


The Forum post is edited by MarkieMark67 May 11 '13
Bekir Eyiengin
Bekir Eyiengin Jun 5 '13
I needed days and hours to solve te cron problem. Finally, three things were important:

1. run.php tries to read /ow_includes/init.php
Make sure that the file init.php has correct permissions (e.g. 755).

2. Write the path to your php-server into run.php. My first line in run.php reads:
run.php also needs read/execute permissions.

3. My server (hosteurope.de) wouldn't accept the suggested order "commands + path to run.php". I need to change the order like this:
www/ow_cron/run.php wget -q -O /dev/null

Now it works fine!
dave Leader
dave Jun 5 '13

I have been on several other panels lately and with each one the -O was not recognized so as Mark mentioned it depends on your server setup.  The -q is pretty common and i have not found a server yet that did not recognize it.


Remember that the -q is quiet mode which means no output unless you have output in your cron file itself.  So to test this cron you will need to remove the -q and let it run (just wait a min or two) and you will receive an email (make sure the correct email is in your cron notify on the page)  and then open the email, it will be obvious that it ran successfully by the content of the email. 


Then put your -q back and walk away lol... done


@arik  have you checked to see if they are all going in your junk box.. have the members add your customer service email to their approved list.

The Forum post is edited by dave Jun 5 '13
ross Team
ross Jun 5 '13


Probably, you haven't configured your Cron Jobs properly, here's the instructions

Find “Cron Jobs” icon in your cPanel

insert this command as it is shown on the image:

wget -q -O /dev/null http://www.yoursite.com/ow_cron/run.php

and choose "Every minute" for the "Common Setting" as it is shown on the image

Note: replace http://www.yoursite.com/ with your actual domain name.

Hope it will help. 

Please, let us know

dave Leader
dave Jun 5 '13

and if you get an error useing wget, it means that wget has not been configured on your server in that case there are other choices.  Here is a fairly common one that will prob work.


php -q /home/YOUR cPanel USER NAME/public_html/YOURDOMAIN.com/ow_cron/run.php