We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

New Install - Fatal Error [Solved] | Forum

Trina Clark
Trina Clark Jun 15 '13
I've searched the forum for a couple of hours, but I haven't seen this addressed anywhere.

New installation using Softaculous. When I try to view either the public or admin home page:

Warning: require_once(/home/digi/public_html/friends/ow_includes/config.php) [function.require-once]: failed to open stream: Permission denied in /home/digi/public_html/friends/ow_includes/init.php on line 25

Fatal error: require_once() [function.require]: Failed opening required '/home/digi/public_html/friends/ow_includes/config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in/home/digi/public_html/friends/ow_includes/init.php on line 25

The Forum post is edited by ross Nov 19 '13
dave Leader
dave Jun 15 '13
whats the permission on the ow_includes folder now?  It should be no less than 755
Trina Clark
Trina Clark Jun 16 '13
The ow_includes folder is set at 755.

Here is the conversation with my host so far:

Host: I have checked this in detail and I am also getting the same error while checking your site on server backend. It seems to be a problem with the scripts. You may contact developer of this script to resolve this. Let me know if they suggest any php variable settings or permissions need to be changed on server side to work this script.

Me: Ok. I just thought it was odd that two different scripts (from two different developers) are coming up with similar errors. After I installed Oxwall, I checked their forum for information about the problem. Didn't find a solution, so I posted a message and am waiting for a response.

In the meantime, I tried changing permissions on the includes/config.php file to 755 and received a 500 Error. I've since changed the permissions back to 400, so the original error is back.

Afterward, just to see if it was possibly something to do with my server, I decided to install Sharetronix...which results in a very similar error.

Host: I see the following error in the error log of your account.

[15-Jun-2013 15:17:36] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/timezonedb.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/timezonedb.so: cannot open shared object file: No such file or directory in Unknown on line 0
This error was due to "timezonedb.so" module which was not installed on your server. I have installed it on your server using the command "pecl install timezonedb" and the error went away. But, the main error is still persisting while accessing those of URL's. I would wait for their response and see what they can suggest on this.

I just tried uninstalling and reinstalling Oxwall, but I'm still getting the same error.

The Forum post is edited by Trina Clark Jun 16 '13
dave Leader
dave Jun 16 '13

As far as i know the Softaculous does not double check for proper permissions so you might want to try to dowload the script and install it manually, once you install it will tell you the files you need to change to get proper permission access.  Unfortunately with all the different server setup variations out there Softaculous installs at times have issues and this is not isolated to Oxwall, it is Softaculous wide.  


Oxwall is very easy to install manually.  http://docs.oxwall.org/install:manual_installation

Trina Clark
Trina Clark Jun 17 '13
Thank you, Dave.

Trying a manual installation now.

The Forum post is edited by Trina Clark Jun 17 '13
Trina Clark
Trina Clark Jun 17 '13
Everything seems to be perfect! And you're right...it was very easy.
dave Leader
dave Jun 17 '13
your welcome and so glad its working for you :)