We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

db upluad error | Forum

omer Oct 21 '13

i am uploading with phpmayadmin my db  to new server

but i am recieved this error message

"/*!40000 ALTER TABLE `ow_base_geolocation_ip_to_country` DISABLE KEYS */;"

what is the problem

dave Leader
dave Oct 21 '13

1. did you import your DB using the same export from the old DB on the old server

2. are you keeping the same domain name


when i uploaded one of my sites after a move one time i had one little error for some reason. So i opened the sql file, and cut out the section that was giving me a problem (both the structure and the data)  and pasted that into another file.


then i ran the main sql again with that part out and it ran fine.  Then i ran the other file by itself and it ran fine too.  Sometimes doing large imports phpMyAdmin can be fussy. 

The Forum post is edited by dave Oct 21 '13
Alia Team
Alia Oct 28 '13
Omer, I am not a great database specialist, but as far as I know the notice above is not an error.

"The line above acts like a comment depending upon the version number of MySQL. It will execute if the dump file is imported into a version of MySQL later than version 4.0, otherwise it will be ignored. This is very helpful in assuring that the syntax of the dump file will be compatible across most versions of MySQL."(c)
omer Oct 30 '13
ok resolved... i uploaded by the cpanel Backups 
The Forum post is edited by omer Oct 30 '13
dave Leader
dave Oct 30 '13

great, glad to see you got it resolved..


+1 Aliia, that went right over my head and I knew that too...



I just assumed he had a problem and thought it was giving him an issue, but  now that I look close he must have mistaken that for an error when its not..    oops.. ;)

dave Leader
dave Nov 6 '13

Actually Aliia guess what i did have this similar thing happen to me just today... Here is why it happened and i never thought about this..


to restore a customers oxwall db was 53 MB,  phpMyAdmin limit is 50mb but even cutting that down to 30MB it timed out.


So what i had to do was cut the db into 5 parts, with the last part (part 5) having just the two last watchdog tables. 


after this (which is the end of the sql file) there is this part...


-- Dumping routines for database 'xxxxxxx_oxdatabse'


-- Dump completed on 2013-11-05 16:09:50

i did not remove this part and so i got an error that said something like




-- Dumping routines for database 'xxxxxxx_oxdatabse'


cannot set time zone to null



so what i think happens Aliia is that if you leave the comments in the beginning of the sql file then you have to leave then at the end,  and since i did not have any at the beginning of this file becaue it was a split off.  It bombed when it saw those.


So all i did was just remove all those comments at the end of this part5 and it uploaded perfectly.


Just fyi...  :)



The Forum post is edited by dave Nov 6 '13
Sen Projects
Sen Projects Nov 6 '13
There are great tools too for db backups and imports aside from the usual phpmyadmin. One

is the MySql Workbench  and there is another great tool like SQLYog  but this one is not free. This one is free, Heidi Sql

Or you can check this page for Top 10 Mysql Tools 


Alia Team
Alia Nov 6 '13
Thanks for sharing Dave.
Alia Team