We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

There is no active plugin with key `PHOTO`[Answered] | Forum

Otis Nov 2 '13
I deactivated the photo plugin by accident, now I get a 500 internal server error

on the server, the message basically states, there is a disconnection between the photo plugin.. how do I reactivate, I am not able to log into the admin section

The Forum post is edited by ross Nov 19 '13
Dave S
Dave S Nov 3 '13
Just upload the plugin to FTP and done. Clean the cache if it needs.
Otis Nov 3 '13
the plugin is in the right directory, I still get this message


There is no active plugin with key `PHOTO`






#0 .../ow_core/default_route.php(65): OW_PluginManager->getPlugin('PHOTO')

#1 .../ow_core/router.php(304): OW_DefaultRoute->generateUri('PHOTO_CTRL_Phot...', 'ajaxResponder', Array)

#2 .../ow_core/router.php(290): OW_Router->uriFor('PHOTO_CTRL_Phot...', 'ajaxResponder', Array)

#3 .../ow_plugins/gphotoviewer-2/init.php(28): OW_Router->urlFor('PHOTO_CTRL_Phot...', 'ajaxResponder')

#4 [internal function]: photoviewer_script_render(Object(OW_Event))

#5 .../ow_core/event_manager.php(188): call_user_func('photoviewer_scr...', Object(OW_Event))

#6 .../ow_core/application.php(348): OW_EventManager->trigger(Object(OW_Event))

#7 .../index.php(76): OW_Application->finalize()

#8 {main}



ross Team
ross Nov 4 '13
Otis have you deleted the plugin manually, because this is a common error, the one you get, when you delete plugin manually from the server. 
Kostia Mar 1 '14
the same problem
ross Team
ross Mar 2 '14
the same question - have you deleted the plugin manually
Kostia Mar 3 '14
i had turn it off on cpanell and seeing 500 error ( ..There is no active plugin with key `PHOTO`...)
ross Team
ross Mar 3 '14
What do you mean by turning off on cpanel? Plugins can be deactivated and uninstalled via Admin Panel only. If you deleted the plugin folder via CPanel, now you need to clear the remains in the database in order not to get this error. 
Kostia Mar 4 '14
i deactivated it;] 
ross Team
ross Mar 4 '14
please, provide details how you deactivated it via CPanel
Kostia Mar 5 '14
on admin panel;]
ross Team
ross Mar 5 '14
Ok, you confused me, earlier you said that you turned it off on cpanel, now on admin panel. Anyway, when you enable it again, you still get the error?
Kostia Mar 6 '14
yes, i upload plugin on ftp again but it still shows me 500 error, now i reinstall all website. 
ross Team
ross Mar 6 '14
Kostia, why do you upload plugin again if you just deactivated it via admin panel.

please read this post: http://www.oxwall.org/forum/topic/13871