We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Can anyone help me solve this problem.[Solved] | Forum

Modern
Modern Jan 30 '14
I have my Oxwall site set up in www.modern-nationalist.com/groupware

There is a file index.php in the public.html directory that the following error message refers to.

The problem I am having is that when people log onto www.modern-nationalist.com they are just getting a white page.

>]: Failed opening required '/home/modernna/public_html/ow_includes/init.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/modernna/public_html/index.php on line 30 [31-Jan-2014 00:06:17 Europe/London] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/zip.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/zip.so: cannot open shared object file: No such file or directory in Unknown on line 0 [31-Jan-2014 00:06:17 Europe/London] PHP Warning: require_once(/home/modernna/public_html/ow_includes/init.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /home/modernna/public_html/index.php on line 30
The Forum post is edited by ross Feb 9 '14
ross Team
ross Jan 30 '14
Modern, you don't have module zip.so or there's a problem with it. Please contact your hosting provider to check that issue. Also check if there's init.php file in ow_includes folder. 
Modern
Modern Feb 6 '14
I solved that problem by using this bit of code in the htaccess page in the public.html folder.  I just put my site name where it says yourwebsite and the groupware folder name where it says website_folder and it worked ok.

Sub Domain Redirection

Sub domain redirection mapping to folder. Here http://www.yourwebsite.com is connecting to website_folder folder.

RewriteCond %{HTTP_HOST} ^www\.yourwebsite\.com$
RewriteCond %{REQUEST_URI} !^/website_folder/
RewriteRule (.*) /website_folder/$1

ross Team
ross Feb 9 '14
Thanks for updating. I'm going to mark this thread as Solved.