We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Fancybox now working under v1.2.4 build 4230? - Fancybox | Forum

Eric Sep 17 '11
I upgraded my Oxwall installation to v1.2.4 build 4230.
Everything seems to work as expected.

After the update I installed the Fancybox plugin, but that does not seem to work.
When I click an image in a blogpost or photo album, I do not get the Lightbox effect.

There are no configurable settings for Fancybox, so I assume it should work right out the box.
Am I correct?

Honsa Sep 18 '11
same here, updated the demo environment too and cannot reproduce your issue:

yes fancybox should work out of the box after activation
The Forum post is edited by Honsa Sep 18 '11
Honsa Sep 18 '11
may it helps if you clean your ow_smarty/template_c/ folder, but i dont think so
Den Team
Den Sep 19 '11
Topic was moved from Plugins.
Eric Sep 20 '11
Hello Honsa,

I tried your suggestion to empty the ow_smarty/template_c folder.
Unfortunately, to no avail.
If I read correctly, Fancybox only supports images posted in forums?
I have seen the hack to enable it for other sections too.
Anyway, I entered a forum post with an image and it doesn't zoom when clicked.
Instead, it opens in a separate tab.

Eric Sep 20 '11
Hello Honsa,

I noticed that in your link you are using a photo album.
I tested that as well, and that does not work either.

Honsa Sep 28 '11
I tested it again, with IE and chrome and it works.

you mean this link:


edit: oh and fancybox works at the moment just on photo plugin, if you want to use it on forum pictures you have to change some details...
The Forum post is edited by Honsa Sep 28 '11
Eric Oct 3 '11
Hello Honsa,
I've been away for a couple of days, so couldn't get back to you earlier. 
I suspect you tested Fancybox against an Oxwall installation in the root of your website?
I'm running Oxwall from a subfolder, and that is what causes the problem.
If you take a look at the end of webpages incorporating Fancybox, you'll notice that  Fancybox support files are included using relative URL's, i.e.:

<script type="text/javascript" 

As you can see "/site-1/ow_static/plugins/fancybox..." is relative to the server root, and not the website's root, which is "www.gladbags.com./site-1/".

You can probably fix this by changing the relative links to absolute links, as used by other components. 


Honsa Oct 13 '11
you are right, thanks for your advice, i will change it in next versions
Niels Nov 8 '11
Since I'm running Oxwall from a subfolder too, can anyone give me advise how to change relative links to absolute as described by Eric, so I can use the Fancybox plugin?

Honsa Nov 16 '11
use your complete url
You do not have permission to reply this topic