We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Fresh install of 1.7: "/install was not found on this server" | Forum

Heri Bender
Heri Bender Aug 3 '14

VM ubuntu 12.x (static IP 192.168.99.1)

Apache 2

MySql 5.x


unzipped the downloaded oxwall-1.7.0.zip file into /var/www/oxwall17

After browsing to 192.168.99.1/oxwall17 apache moans error:

"The requested URL /oxwall17/install was not found on this server"


192.168.99.1/oxwall17/ow_install/install    -> same not found error

192.168.99.1/oxwall17/ow_install/install.php    -> browser shows a blank page


There are several other php servers beside this oxwall installation in /var/www which all work perfectly.


I tried also to with chmod 777 on all oxwall files -> same result

Daisy Team
Daisy Aug 4 '14
Make sure that you have mod_rewrite enabled on your server. Also, please check if your server meets our requirements: http://www.oxwall.org/hosting.
Heri Bender
Heri Bender Aug 4 '14
Super. Thanks! That did it.


Here two Links which explain perfectly the enabling of mod_rewrite:


http://stackoverflow.com/questions/869092/how-to-enable-mod-rewrite-for-apache-2-2


and 


http://www.jarrodoberto.com/articles/2011/11/enabling-mod-rewrite-on-ubuntu

Daisy Team
Daisy Aug 4 '14
Heri, thank you for the information. I believe other developers will find this information useful.
tammy harris
tammy harris Aug 5 '14
install should not be in /var/www/

should be in 
/public_html

/var/ is in the top levels of server 
Heri Bender
Heri Bender Aug 5 '14
The DocumentRoot of my apache installation is /var/www  (I changed it from /var/www/html in apache2.conf)

In this folder there are several other PHP web applications, including the original html folder which displays the apache welcome screen.

That way, when I connect to URL http://myhost:80, apache displays the list of subfolders as link. Choosing "html" from this list, it displays the apache welcome screen (html/index.php), choosing "oxwall17" leads to the oxwall application (oxwall17/index.php). Or I can enter the URL directly as http://myhost:80/oxwall17 ;

The Forum post is edited by Heri Bender Aug 5 '14
tammy harris
tammy harris Aug 5 '14
Try install in correct place now see if works as being in top levels will load the site before the rest of the serve configuration stuff

My understanding is noting should be installed in www folder

Daisy Team
Daisy Aug 6 '14
Tammy, it's up to the apache setting - would it be /var/www/ directory or
/public_html. Both places are correct. You can even create your 'test' directory, change the apache setting and use it as your root directory.
tammy harris
tammy harris Aug 6 '14
ok cool is good to know i may use that