We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Infinite loop when installing Oxwall on XAMPP | Forum

Stachu Kozłowski
Stachu Kozłowski Aug 11 '14
Hi, i tried to install Oxwall on my localhost (i'm using XAMPP) but when i try install my browser say "incorrect redirection" after step "Create a cron job that runs ow_cron/run.php once a minute.". Please, help me if you know what.

ross Team
ross Aug 11 '14
Topic was moved from Bug reports and troubleshooting.
ross Team
ross Aug 11 '14
What Xampp and Oxwall versions do you use? What OS do you use?
Stachu Kozłowski
Stachu Kozłowski Aug 11 '14
Windows 7, latest XAMPP and latest Oxwall (1.7.0).
ross Team
ross Aug 11 '14
Can you please, try to install again, but not on the latest version of Xampp? 
Stachu Kozłowski
Stachu Kozłowski Aug 12 '14
I try on XAMPP version from March 2011 but the same effect :(
ross Team
ross Aug 12 '14
Stachu, we just tried to install latest Oxwall on 1.8.2 Xampp and it works perfectly. Something is wrong on your end. Since it is local installation we cannot tell you what exactly. 
Stachu Kozłowski
Stachu Kozłowski Aug 12 '14
Okay, thanks. It should be problem with my PC, thank you very mutch.
arash tavanaei
arash tavanaei Mar 15 '15
try this:

unzip oxwall package again in htddoc

go to ow_install/install.php


$data['password_salt'] = uniqid();

add following code after that:

$data['db_password'] = "";

now run install

Christophet Sep 17 '15
I have the same problem and I can't find the line Arash is referring to (Oxwall 1.8.0)
ross Team
ross Sep 18 '15
No need to look for that line. 

Have you checked your localhost meets our server requirements: http://www.oxwall.org/hosting Seems like you don't have mod_rewrite module enabled or configured properly. 

Christophet Sep 18 '15
mod_rewrite module was already enabled ,  thanks anyway :(

Hybrid Sep 19 '15
Having same issue now...

After uninstalling and reinstalling XAMPP, I changed the port to 8080 from 80 for Apache.

Then when going into phpmyadmin and creating a database, I also created a user with a username and password and gave it a wildcard which allows all privileges to this user for the database I created for oxwall...Doing this solved my issues here: http://www.oxwall.org/forum/topic/41153

However, now that that issue is solved, I am running into a redirect loop... :/ 

when trying to finish the installation process.

Any ideas?

The Forum post is edited by Hybrid Sep 19 '15
Hybrid Sep 20 '15
So, after digging a bit deeper and trying many things, I believe the issue lies within the .htaccess file(s).

Just to make sure that this wasn't a "cookie" issue, I cleared all cookies - error still occurs.

I also tried installing wordpress to see if the issue occurs on that software, but I was able to install that with no problem and no errors - meaning it has to lie within the oxwall software somewhere...If it didn't, I wouldn't have been able to install wordpress as it would produce the same results (eg: redirect loop).  But since wordpress installed just fine and using the same xampp (apache & mysql) setup, it has to lie within oxwall somewhere.

So I dug a bit deeper...I noticed, for starters that wordpress has absolutely NO .htaccess files...and oxwall has several (most of which are "Deny from all" files within certain folders)...The only one that has more information on it is the main .htaccess file within the main directory folder of oxwall.  It has several "Rewrite" conditions/rules along with a few other things.

So I tested out multiple times to see if I could eliminate the problem.  First, I deleted all the .htaccess files, however, that didn't work at all - doing that I couldn't even open up the first page to install the software...Then after another attempt, I tried just modifying the main .htaccess file.  I tried multiple approaches on this (1) deleted all within - that didn't work...(2) Tried to eliminate only the "rewrite" stuff on it - again, did not work...(3) Tried adding "-Mulitpleviews" next to "Options -Follow..." line - but that didn't work...(4) Tried adding "RewriteBase /" and even "RewriteBase /oxwall-1.8.0/" - but neither one worked as the first redirected me to the dashboard on xampp and the second one did nothing...

So, I guess with what I've done, I hope to have eliminated some potential thoughts of why this is occurring but sadly - none of those potential solutions worked...and other than that, I honestly have no idea why this isn't working and it continues to give me a "Redirect Loop" after I click the continue button on the plugin page installation (the last step)...

I meet the requirements needed - or at least I believe I do...I am a bit unsure about one thing, so hopefully someone can answer this at least.

In the phpinfo(); file, it states that I have "loaded modules" which the "mod_rewrite" is mentioned - Does that mean that module is enabled?  Or do I have to go into the php.ini file and enable that somehow even though it says that it is a "loaded module"...?

Other than that, I hope we can brainstorm more ideas of why this is occurring (the redirect loop that is)...because I'm at a complete loss...

Installing the software on my domain works just fine, but I'd like to have the software on my localhost to try and start creating "themes" and "plugins" in a faster environment...

The Forum post is edited by Hybrid Sep 20 '15
ross Team
ross Sep 21 '15
Hybrid, loaded modules do not mean that the modules are enabled, they are just installed. 
ross Team
ross Sep 21 '15
On local server, you can enable modules directly via the fast access menus, when you click on the server icon in the toolbar, it shows you additional options, there you can see the php modules, apache, etc, make sure mod_rewrite has check mark next to the mod_rewrite module. 
Hybrid Sep 21 '15
I'm pretty sure mod_rewrite is on.  After looking in the httpd.conf file in apache this line:

LoadModule rewrite_module modules/mod_rewrite.so

is not commented out (eg: Does not have a '#' sign in front of it - therefore, it should be enabled.

Also, I checked a few other things as well such as the:

<Directory />

AllowOverride None

Require all denied


I changed the value of "None" to "All" and "denied" to "granted" - but unfortunately, this did not work either...

So I'm assuming this has nothing to do with the mod_rewrite.

Any other suggestions on how to fix this redirect loop issue?  I'm literally at a complete loss...

The Forum post is edited by Hybrid Sep 21 '15
Hybrid Sep 21 '15

So, I found this forum topic that uses different software, but has had similar issues...Here is the link: http://www.yiiframework.com/forum/index.php/topic/24131-this-webpage-has-a-redirect-loopthe-page-isnt-redirecting-properly/page__view__findpost__p__117586

In a nut-shell, post #2 says that it has something to do with the software trying to redirect the user back to the users page (or allow all users to perform 'index' and 'view' actions...With that said, where would I find the code to modify it a bit to allow and/or grant me everything I need so I don't have to worry about a redirect loop?

Basically, since this is on localhost, I'm the only one who is needing to perform these actions anyway as I'm not wanting the public to 'index' and 'view' it...just me.

So is this something to be concerned with and need in order to stop these "redirect loops"?  And if so, how would I accomplish this (modifying what goes where)?  And after doing that, would I need to modify anything in the database?  Or is this all irrelevant?

ross Team
ross Sep 22 '15
Provide the content of your htaccess file which is in the root of the software. 
Hybrid Sep 22 '15

Options +FollowSymLinks

RewriteEngine On

AddEncoding gzip .gz

AddEncoding gzip .gzip

<FilesMatch "\.(js.gz|js.gzip)$">

  ForceType text/javascript


<FilesMatch "\.(css.gz|css.gzip)$">

  ForceType text/css


RewriteCond %{REQUEST_URI} !^/index\.php

RewriteCond %{REQUEST_URI} !/ow_updates/index\.php

RewriteCond %{REQUEST_URI} !/ow_updates/

RewriteCond %{REQUEST_URI} !/ow_cron/run\.php

RewriteCond %{REQUEST_URI} !/e500\.php

#RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]

RewriteCond %{REQUEST_FILENAME} (/|\.php|\.html|\.htm|\.xml|\.feed|robots\.txt|\.raw|/[^.]*)$  [NC]

RewriteRule (.*) index.php

Pages: 1 2 »