We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Update on 1.2.6 killed my site, Backup doesn't work... HELP! :( | Forum

Hati Narcatis
Hati Narcatis Nov 10 '11
I've updated oxwall manually to 1.2.6 and after a short period of time when everything worked fine, this error message came up and nothing worked anymore.

I tried to play back the database backup I've made right before, but the error was still there.
Site is in DEV-mode and DEBUG-mode

Please help! :(

  error.png (56.07Kb)
Hati Narcatis
Hati Narcatis Nov 10 '11
Err... I fixed it.

For those who are interested in the solution:

I've accidently deleted the temp folder for MySQL

St00pid admin was st00pid :B

close plz
Michael Leader
Michael Nov 11 '11
Nooooo keep it open!  we learn from these things!  LOL!

Great job you got it, great call in backing up first.  so many people wont!
Did you retry the manual update?  I have done a couple of manual 1.2.6 updates and it was fine.
Hati Narcatis
Hati Narcatis Nov 16 '11
Sorry for the late reply ^^'

Yes, I did the manual update and followed my usual simple steps:

1.) Maintenance-Mode
2.) Backup of database
3.) Backup of files
4.) Downloading update files
5.) Replacing all files on server with updated files
5.) Edit my application.php because I use HTTPS
6.) Open www.mydomain.eu/ow_updates
7.) Check if everything works fine => if not: try DEV-mode or restore Backup
8.) Disable Mantenance-Mode
9.) ???
10.) PROFIT!

Almost 1500 registered users thank me for that ^^
The Forum post is edited by Hati Narcatis Nov 16 '11
Chris Dec 21 '11
Hi, I'm going to update my install from 1.1.1 to 1.2.6 and your guide above is quite useful, is there anything else i should do to make it go as smoothly as possible?

Michael I.
Michael I. Dec 22 '11
Chris, just make sure you updated all the source code and database before the update. That is crucial to make backups before your run an update of your website. If something goes wrong during or after the update, post a reply here and you'll get help if needed.