We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

admin+plugin_update_download_error in updating 1.2.6 | Forum

Manhar Nov 27 '11
we successfully core updated ... and we facing error while updating various plugins ... 

like, blog, friends, links .. 

please check it ... and we also made DEV MODE " TRUE " .. 
Michael I.
Michael I. Nov 28 '11
Hi Manhar. We need more details like what errors you receive? Screenshots and details on what plugins you were trying to update would help.
Manhar Nov 28 '11
Hello .. Dear ! 

I was trying to update friends plugins ... and system gives me that error ... screen shot attached ...
  admin_update_error.jpg (174.8Kb)
Michael I.
Michael I. Nov 29 '11
Please check if php directive url_fopen is enabled on your server.
Manhar Dec 1 '11
dear .. other plugins updated easily with 1.2.6 ... but these plugins like, groups, blogs, likes, friends and news feed ... while updating this plugins i am facing this problem .. 

idea Dec 3 '11
ya dear developer that's the main point we have updated the site to 1.2.6 from admin panel (auto update) successfully with few other plugins as well but not six plugins they are showing the error as stated above... :( and ya 

 its enabled on the server.
allow_url_fopen On

Please help to resolve it ASAP cause if you release new version then the risk will increase and also chance of site crash..
The Forum post is edited by idea Dec 3 '11
Manhar Dec 5 '11
any cluuuu
Keelan Leader
Keelan Dec 5 '11
How are you updating the plugins? Manually upload them then head over to the plugin area and you will be prompted to update them.
Manhar Dec 5 '11
yeah ... i am getting notification about plugins update in my admin panel .. 
Keelan Leader
Keelan Dec 6 '11
Then you try and it fails?
Manhar Dec 6 '11
exactly .. i am trying to update plugin in admin panel and it fails .. 
idea Dec 8 '11
what exactly happened stated below again

# we got update notification for both core as well as for plugins
# we decided to update hence modified config.php and set 
define('OW_DEBUG_MODE', true);
define('OW_DEV_MODE', true);
define('OW_PROFILER_ENABLE', false);

#updated core to 1.2.6 from admin panel (ie auto update - recommended)

update of core was successful

# then started to update plugins (there was more then 12 plugins update i think) through admin panel same as that of core update we succeed in all the plugins except - friends, blogs, groups, links, newsfeed and oxwall CS image slider were updated successfully as that of core.
but when ever we start autoupdating the above six plugins it gives the error msg as stated in above given screen shot.

# we checked that url_fopen is enabled on server as you asked for.

Please help on this issue asap as we like to be upto date with the oxwall.


The Forum post is edited by idea Dec 8 '11
Keelan Leader
Keelan Dec 8 '11
Does your host meet the requirements?

http://www.oxwall.org/hosting  (right hand side)

Have you tried doing this with dev and debug mode false?

Are you just clicking update? Or are you downloading them from the store then unpacking them and uploading them via FTP to the correct folders then updating them in the admin panel?
Michael I.
Michael I. Dec 9 '11
Manhar or idea (not sure who is in charge), send me your FTP, phpMyAdmin and Admin Panel access details so that I could check into the issue.
idea Dec 9 '11
i'd PM you please help asap 
#Try to update plugins
#Visit admin> available theme see the messup.
#and the java catch in phpmyadmin
idea Dec 12 '11
no updates dear
Michael Leader
Michael Dec 14 '11
Check chmod on the folders is set right?
Try manually updating the plugins using ftp see if that works?
idea Dec 15 '11
#ya they have proper chmod

#when tried first time uploading through ftp manually plugin updated asked for "update dbase" clicked yes.. all the data of the plugin lost (LInk plugin)..! (dev_mode and debug mode kept true and core software with few more plugins were updated with auto update perfectly and successful also..!)

#when tried second time rest of 6 plugins that not updated through auto update, tried to update them through ftp manual keeping dev mod and debug mod true all plugins updated successfully with out loss of data...!

#surprisingly .htaccess file content were erased automatically accept index file each thing on the site didn't worked. then replaced that file with the old .htaccess file having its natural code. the site worked as it should be.

still have few questions that are remain as they were..

# why auto update of plugins didn't worked?
# why whole data erased when i updated "link" plugin manually keeping dev_mode true.?
#why .htaccess file got empty?
#why still my theme is not working properly (check - current theme is grafite+sidebar but there is no sidebar..!)?
idea Dec 21 '11
at current stage there is now no way to resolve this issue as i updated them through ftp
still following question remains unsolved
#why it didn't downloaded the file?
#why the data were deleted during ftp update?
Michael I.
Michael I. Dec 22 '11
It is difficult to answer those questions w/o having an option to check into the issue. We'll keep monitoring the issue and will let you know if we have any news regarding this report.