We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Softaculous - FYI | Forum

Joe Nov 10 '14
I just performed a quick install through Softaculous to test a theme I'm working on. I kept getting a blank screen at the url. I enabled dev mode and still a blank screen. So:

- I FTP'd the update pack
- Called mysite.com/ow_updates
- Success. Message said I had the latest version. Went to main site and logged in.
- Admin panel showed 8 plugins and 3 theme updates available and cron needed to be configured.
- Everything working fine now.

Just an FYI if anyone is having problems with Softaculous installs.

BTW, Wordpress installed fine. Seems to be just the Oxwall install.
Durlabh Ashok
Durlabh Ashok Nov 11 '14
Hello Joe,

Are you still having problems? or it is solved?

Joe Nov 11 '14
Yes, it's solved thank you. I just wanted to let other users, who may have Softaculous issues, know what I had to do to resolve it. Or if the team wanted to know about it.
The Forum post is edited by Joe Nov 11 '14
ross Team
ross Nov 12 '14
Joe, we just recently tried to install the software via softaculous and did not have this problem. 

Can you please try again, and provide us with the screenshot of every step you took?

Joe Nov 12 '14
Hi Ross - Here are the screens. I left the site as is and will pm you login details if you want to have a look around.

Now if I upload the update pack from oxwall site via ftp and call .../ow_updates it will start working with 8 plugins that need updating. But I left it as so so you can look around.
  Screens.pdf (1949Kb)
ross Team
ross Nov 13 '14
Joe, you don't have PDO module enabled on your server 

contact hosting provider and request to enable it, please. Then I'll proceed. Keep me updated. 

Joe Nov 14 '14
Done. PDO enabled.
ross Team
ross Nov 17 '14
I get this error in error logs:
PHP Fatal error:  Undefined class constant 'MYSQL_ATTR_INIT_COMMAND' in /

you need to enable pdo_mysql.so extension. Conact your hosting provider to do that

as I still get the same no value for PDO as in the screenshot

Joe Nov 17 '14
I'm still waiting to hear back from Arvixe again. It's been almost 12 hours now and I sent a second request.

The last I heard from them was on Friday:

"I have enabled the PDO in the account. The website xxxxxx.com/social/ is loading without any error. Please check it and let us know."

I'll update soon, I hope.
ross Team
ross Nov 17 '14
Alright, no problem. 
Joe Nov 18 '14
Ross, I installed Oxwall on another site for Arvixe to look at. I pm you their response and additional login info. I still don't know if this is a hosting, Softaculous, Oxwall or combination issue. Thank you so much for your time!
The Forum post is edited by Joe Nov 18 '14
Pulkit Nov 29 '14

I am from the Softaculous team. We have tested Oxwall installation on several test servers and it seems to work fine.

It looks like some requirements are not configured on the server which might be causing the issue.

If you can open a support ticket we can check this issue for you.
ross Team
ross Nov 30 '14
Pulkit, the issue Joe was having is that while installing manually, everything works as it should be, when installation is done via Softaculous, for some reason there's no PDO for that installation in php info it has no values, however it should have something like sqlite, mysql and others, which is why the site was blank. 

I recommended Joe to contact provider to resolve the issue. However still have not heard back from him. 

The Forum post is edited by ross Nov 30 '14