We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Migration to another machine | Forum

Topic location: Forum home » Support » General Questions
Eiji Hamano
Eiji Hamano Nov 13 '14

I have a test of the migration of machine to machine in 1.7.1.

Please advice because it does not go well.

My procedure was to reference http://www.oxwall.org/forum/topic/24134.

At the from machine:

1.  deactivate all third-party plugins.

2.  turn on 'maintenance mode" 

3.  zip -r  backup.zip * .htaccess;

4.  mysqldump --opt --user= --password= --database xxxx > backup.sql;

At the to machine:

5.  create  database yyyy;

6.  grant all privileges on yyyy .* to .....;

7.  mysql -u root -p yyyy <  backup.sql; 

8   unzip  backup.zip;   

9.  change  'OW_URL_HOME' 'OW_DB_USER' 'OW_DB_PASSWORD' and 'OW_DB_NAME' in ow_includes/config.php

10. turn "maintenance Mode" off.

11. activate all third-party plugins.

It is almost no problem, 

but sometime uploading lang or plugin has make "Error 500" or "xpath() " in To machine.

I want to know the correct procedure of migration.

I think it's crucial thing to the operation of the SNS site.

The Forum post is edited by Eiji Hamano Nov 13 '14
ross Team
ross Nov 13 '14
Please look here: http://docs.oxwall.org/faq:how-to-transfer-my-site-to-another-hosting

Don't forget about the permissions of the folder and files. 
let us know if the issue with xpath persists after changing permissions. 

Durlabh Ashok
Durlabh Ashok Nov 13 '14
+1 Ross
Eiji Hamano
Eiji Hamano Nov 13 '14
Ohh- Here also seems there are many racist person.

He seems bored.

OK ross how about 64bit to 32bit or vice versa?

ross Team
ross Nov 13 '14
It has nothing to do with the architecture type, as the 64bit or 32-bit effects the productivity of your server.  the issue you reported before was related to the permissions of the files created under Apache user(which is Nobody), it gives incorrect permissions. 

You need to contact your hosting provider support team and find out why

Eiji Hamano
Eiji Hamano Nov 14 '14

I found the cause of this problem.

4.  mysqldump --opt --user= --password= --database xxx > backup.sql ;

was the problem. 

When creating same database name,  it makes "xpath() " error.

When creating different database name,  it makes "Error 500" error.

4.  mysqldump --u    -p   -r  backup.sql  -l  xxx ;

was correct.

Ross.  They solve the topic 27395, 27514 and 27764.

I will post to them, from sure once again.

ross Team
ross Nov 14 '14
Eiji, these are practically the same commands, except for the -r in the second one which is used basically for Windows servers. 

I'm glad to hear that you solved your issue. Thanks for letting us know. 

The Forum post is edited by ross Nov 14 '14
Eiji Hamano
Eiji Hamano Nov 15 '14

Certainly -r parameters might be no need in linux.

However in the former, 

we can migrate only in exactly the same DB. Others cannot be.  

And it must be same url structure.  

For example: the migrating  from  /sns  to /  makes these problems.

The latter is possible in different DB name and different url structure.

ross Team
ross Nov 17 '14
Anyway, glad the issue is solved and all other you have reported.