We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Email notifications[Solved] | Forum

Hybrid
Hybrid Jan 6 '15
I'm not sure who to report this too, but for some odd reason, my email notifications just flat out stopped working...


I know it's not my cron job which leads me to believe it has to be a third party plugin...


The only 3 plugins (as of late) that I have updated were the "Members Country Flag", "Anti Brute Force", and the "Smart Captcha"...After applying the update to these 3 plugins, I disabled the last two as I do not need them active for the time being.


Anyway, long story short, the only active one (after applying the update) that I have running is that Members Country Flag plugin - however, I am not getting any errors or nothing...and of course - no email notifications are being sent now...


I deactivated the members country flag plugin and still nothing...


Oh, and I failed to mention that I also have that OxArt Speed Optimizer plugin - every once in awhile I activate it and clear the cache - but after doing so, I deactivate it.  I did this once as well...this plugin is currently disabled.


So overall, I have no idea what is causing no emails to be sent for activity notifications, messages, etc...


No errors - I'm at a loss here - any help would be greatly appreciated.


Oh and I ended up uninstalling the activity notifications plugin and re-installed it - but still nothing - figured I should give that a shot since it states Real-time and email notifications about site activity in the description for the plugin...


But still nothing...

The Forum post is edited by ross Jan 8 '15
ross Team
ross Jan 6 '15
Please check the search results on the forum: http://www.oxwall.org/...mail%20notifications
Hybrid
Hybrid Jan 6 '15

Quote from ross Please check the search results on the forum: http://www.oxwall.org/...mail%20notifications
Not helpful in my case.  Already read through all those and none of them apply to my case...


I suppose I'll have to try Chris_W's suggestion.  I just figured there may have been another way so I wouldn't have to literally un-install everything, then delete it, then re-install it.  Doing that procedure I lose everything...and I'm sure my members will NOT be happy...


So, before I go and do that - anyone else have any suggestions or ideas as to why this is all of a sudden occurring?  Or have we pretty much summed it up and...**sigh** the solution is to lose all content of all members by uninstalling plugins and reinstalling them... :/


---------------------------------------------


Aside from my current situation, which I will leave up in hopes to a legitimate answer too, I do have a suggestion for the entire Oxwall team (including these third-party developers).


Since the Oxwall team is now (or should be back) from their holiday break, PLEASE, do not issue out any new updates until these third-party developers get their stuff working/updated.  Since the latest update version to 1.7.2 back in November, a lot of plugins have not been updated - almost half (if not more) plugins I have are sitting inactive because no update for them are ready - and/or if the plugins work with this latest version, it isn't specified in the description of the plugins...


Might be something to look into to get these third-party developers on the ball with updating their stuff -or- at the very least if the plugins do work, to specify it in their description for each plugin.  With that said, Oxwall team, please do something about this - get these third-party developers attention somehow (PM, email, something) them.


I have a feeling that a new version of oxwall will be coming out soon, and when it does, these plugins will still be lackin' behind.


So, my overall suggestion (besides informing these third-party developers to get on the ball), is: Make an option in the admin panel that allows admins to go from version to version of Oxwall....This would help us out sooo much!  That way, if these third-party developers are behind on getting their plugins updated, us users (admins) can resort to going back a version where the plugins are compatible...and when the plugins are then ready, us admins can switch back to the latest version of Oxwall!


Something needs to be done here...and posting this suggestion on User voice is just silly....we are here on the forums - you have a team who checks these forums - Oxwall team who checks these forums, relay this to the devs of Oxwall.  We all know its a feature that needs to be built-in...


Lastly, I apologize for my rant - just wanted to put in my 2 cents.  Please take it into development asap!


-----------------------------



Back to my original post - I don't plan on uninstalling plugins, deleting them, and then reinstalling them again until this coming weekend IF I have too - so hopefully we can find a solution before then.



ross Team
ross Jan 6 '15
Try to do mass mailing, before doing that open your database via phpmyadmin, ow_base_mail table, see if the mail comes there and goes out from there, to make sure cron is configured properly.

What do you mean those cases do not apply, they are all about notifications not working and all of them contain some instructions how to detect the problem or some solution.
Hybrid
Hybrid Jan 7 '15
Mass mailing works just fine - checking the database, the messages show up and then disappear as they should...However, those emails are not being sent either...


So overall, all email notifications and even regular emails are not being sent.


I know my cron is setup correctly as well as my smtp details as I haven't messed with those settings since day 1 (well over several months ago).  This just started occurring 3-4 days ago where email notifications are not being sent.


Aside from third-party plugins, could it be something with the clients email accounts?  As in gmail, hotmail, yahoo, etc.?  And if so, how would we know or fix that if it is?


And what I meant by those cases do not apply to me is that I've read through and tried all those suggestions - but to no avail...nothing worked...


I am still not receiving any error messages either...

ross Team
ross Jan 7 '15
Hybrid, if the mails go out from the ow_base_mail table, software is no longer responsible for these mails, something is wrong with the smtp server. You need to contact them (smtp company) to resolve the issue. 
Hybrid
Hybrid Jan 8 '15
Contacted - and was told:


"I've checked the server, and I'm finding that the server is operating very well.  I'm not seeing any problems with SMTP or mail in general"


So it has to be oxwall related...

Hybrid
Hybrid Jan 8 '15
Alrighty - not entirely sure what happened here but it appears I am now receiving email notifications again.


Not sure if this was software related -or- if it was my smtp server but everything seems to be working fine again now.


If it changes, I'll update this thread.


The only logical thing I can think of is that my hosting provider for my website fixed something on the email side of things and just flat-out told me that nothing was wrong and everything is operating very well...even though it wasn't...because after talking with him, everything "email" wise is now working, being sent, and being received.  :/


Or - the only other logical explanation is that the software cleared itself somehow...

ross Team
ross Jan 8 '15
Glad it sorted out. I'm going to mark this thread as Solved.