We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

The source code of 'Newsfeed' plugin was updated. Need to update plugin DB. | Forum

Nowthat Feb 27 '12
I tried to update the newsfeed plugin by entering my FTP account info, then the site went to a blank page. I change define('OW_DEBUG_MODE', true); & define('OW_DEV_MODE', true); under thalot/ow_includes/config.php to view any errors. I finally had to remove the newsfeed plugin manually (which was a big no no) and manually uploaded the newly newsfeed plugin to my plugin folder. My site finally came back up but I received this message "The source code of 'Newsfeed' plugin was updated. Need to update plugin DB. " I clicked "update" but the site goes to a blank page. I re-added the plugin but the message stills shows. Any ideas on how to update my MySQL database. I an currently hosting with Host-monster. Users can still access my site fine but I am unable to administer anything from the admin page. I can email my account info if needed. Thanks in advance. Oxwall rocks!!!

Michael I.
Michael I. Mar 1 '12
Did you try running an update one more time following the instructions from here: http://docs.oxwall.org/install:update ?
Nowthat Mar 1 '12
I followed the following instructions.
Manual Update

  1. Download the latest plugin's version from Oxwall Store;
  2. Unpack plugin's archive;
  3. Upload unpacked plugin's folder into ow_plugins/ directory (overwrite existing old plugin);
  4. Login to Admin Panel and click “Update Plugin DB” button;
As soon as I uploaded and overwrited the "newsfeed" plugin with the new one, my website goes blank. So I first, renamed the newsfeed plugin folder to "1newsfeed", I hit refresh and the site comes back up. Of course the site gives this error.

OW Debug - Warning Message: include(/home4/(my root folder)/public_html/thalot/ow_plugins/newsfeed/init.php) [function.include]: failed to open stream: No such file or directory File: /home4/(my root folder)/public_html/thalot/ow_core/plugin_manager.php Line: 103

 OW Debug - Warning Message: include() [function.include]: Failed opening '/home4/(my root folder)/public_html/thalot/ow_plugins/newsfeed/init.php' for inclusion (include_path='.:/usr/lib64/php:/usr/lib/php') File: /home4/(my root folder)/public_html/thalot/ow_core/plugin_manager.php Line: 103

Message: include(/home4/(my root folder)/public_html/thalot/ow_plugins/newsfeed/components/site_feed_widget.php) [function.include]: failed to open stream: No such file or directory File: /home4/(my root folder)/public_html/thalot/ow_core/autoload.php Line: 110

OW Debug - Warning Message: include() [function.include]: Failed opening '/home4/(my root folder)/public_html/thalot/ow_plugins/newsfeed/components/site_feed_widget.php' for inclusion (include_path='.:/usr/lib64/php:/usr/lib/php') File: /home4/(my root folder)/public_html/thalot/ow_core/autoload.php Line: 110

OW Debug - Exception

Message: Class NEWSFEED_CMP_SiteFeedWidget does not exist

File: /home4/(my root folder)/public_html/thalot/ow_system_plugins/base/components/drag_and_drop_item.php

Line: 158
#0 /home4/(my root folder)/public_html/thalot/ow_system_plugins/base/components/drag_and_drop_item.php(158): ReflectionClass->__construct('NEWSFEED_CMP_Si...')

#1 /home4/(my root folder)/public_html/thalot/ow_system_plugins/base/components/drag_and_drop_item.php(75): BASE_CMP_DragAndDropItem->checkComponent('NEWSFEED_CMP_Si...')

#2 /home4/(my root folder)/public_html/thalot/ow_system_plugins/base/components/drag_and_drop_index.php(105): BASE_CMP_DragAndDropItem->setContentComponentClass('NEWSFEED_CMP_Si...')

#3 /home4/(my root folder)/public_html/thalot/ow_smarty/template_c/%%1D^1D9^1D93D34B%%drag_and_drop_index.html.php(100): BASE_CMP_DragAndDropIndex->tplComponent(Array, Object(OW_Smarty))

#4 /home4/(my root folder)/public_html/thalot/ow_libraries/smarty/Smarty.class.php(1262): include('/home4/my root folder...')

#5 /home4/(my root folder)/public_html/thalot/ow_core/view_renderer.php(100): Smarty->fetch('/home4/my root folder...')

#6 /home4/(my root folder)/public_html/thalot/ow_core/renderable.php(235): OW_ViewRenderer->renderTemplate('/home4/my root folder...')

#7 /home4/(my root folder)/public_html/thalot/ow_core/renderable.php(222): OW_Renderable->render()
#8 /home4/(my root folder)/public_html/thalot/ow_system_plugins/base/controllers/component_panel.php(56): OW_Renderable->render()

#9 /home4/(my root folder)/public_html/thalot/ow_core/dispatcher.php(265): BASE_CTRL_ComponentPanel->render()

#10 /home4/(my root folder)/public_html/thalot/ow_core/application.php(293): OW_Dispatcher->dispatch()
#11 /home4/(my root folder)/public_html/thalot/index.php(65): OW_Application->dispatch()
#12 {main} Type: ReflectionException

Now I navigated to the admin page where it said to update the database. I then go back and rename the newsfeed folder correctly. I click on the update button, and it goes back to a blank page, no access. I saved a backup of my newsfeed folder but that's the one that prompts me to update the database. I tried this step several times. No luck. My site works fine but no admin functions are accessible. Is there any way to update the newsfeed folder manually to believe that the database is already updated? I probably will have to give you admin rights if needed. Thanks in advance.

The Forum post is edited by Nowthat Mar 1 '12
Michael I.
Michael I. Mar 8 '12
You should update core first, then plugins. Consider about installing your website from backup and updating core first.
Nowthat Mar 9 '12
Do I have to use the Data Importer, because if that is the case, I can not access any plugins from the admin page. The admin page is looped on the "update the DB for the newsfeed plugin". I believe I have a old manual backup of the website and not the SQL database.

1. If I use the old backup, will I lose all the current new users and their content?

2. Will I lose the current newsfeeds and posts?

3.After I restore the old backup, do I just follow the instructions you provided me "http://docs.oxwall.org/install:update "?
Michael I.
Michael I. Mar 13 '12
You should create a backup of your database before running an update. After that you should run a manual update following instructions from the http://docs.oxwall.org/install:update manual. No data should be lost.
Nowthat Mar 17 '12
I downloaded the 1.3.1 update and uploaded the folder (see attached pic) to my oxwall root directory. Using Firefox I typed www.thalot.com/ow_updates and I received a blank page.

When I try to do the same thing using google chrome, I get a 500 error. I can't not perform a restore to a older oxwall install because I do not have access to the data imported plugin. My admin page is still stuck at the "newsfeed update db" screen.

I also tried clicking on the auto update button but I still receive a blank page in firefox. Thanks in advance. Any assistance will be greatly helpful. Thanks.
Michael I.
Michael I. Apr 1 '12
You should've extracted files from the update pack first. Please try doing that and run the update one more time.