We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Fresh install - localhost - windows 10 - xampp - cron issues | Forum

Hybrid Sep 16 '15
I have just installed a fresh copy of oxwall-1.8.0 in xampp on windows 10.

For some reason, I am having issues getting cron to work - I've read the documentation (none of it helped) - and have searched through your forums reading thread after thread but nothing...

the server is: windows 10 (OS)

using: xampp / localhost - port=100 rather than 80 due to conflicts with other applications using that port.

I get to the third step when installing, but fall prey to this:

"ow_includes/config.php file is incorrect. Update it with details provided below."

I'm quite confused on how to set this up via localhost...

Do I really need cron setup if all I want is a fresh install and environment where I can develop and test themes?  I don't plan on using it for anything else...so is there really a need to have cron running?

If not, could someone shed some light on this?  For example, if cron isn't needed for those who are developing themes only - is there a copy of oxwall that allows for just this type of environment on a localhost windows based machine running xampp?

ross Team
ross Sep 18 '15
Hybrid, no need to set the cron up. 

Do you replace the config.php file the step before? Or don't you get the new config.php content? 

Hybrid Sep 18 '15
I'm not sure that I follow what you asked in terms of if I replace the config.php file the step before?  Or don't I get the new config.php content?

The step before setting up the cron job in the installation of oxwall is entering the details/info for my database.




Database Name:

Table prefix:

All of this information is correct when I enter it.  But when I click "Continue" and it takes me to the "Install" page (3rd step), it is asking me to setup a cron job.  However, when I click continue, what I posted in my original post is what I'm receiving.

Any ideas?

You mention that I do not need to set the cron up...If that's the case, why am I having issues?  Shouldn't it just by-pass it and let me install the software on my localhost?

vadim Feb 24 '16
its not the cron that the problem. its the database setup step.

on your localhost, probably, your database user password is blank... (and your user name is probably root)

on mine it is too.. so i went to the file ow_install/files/config.txt

and changed the line that says:

define('OW_DB_PASSWORD', '{$db_password}');


define('OW_DB_PASSWORD', '');

i assume that if you have a password for your database user on your localhost, you wouldn't run into such a problem

Steve Feb 24 '16
I had trouble setting up cron in windows so I made a batch file and used Task Scheduler in Administrative Tools to get cron to work.

This website explains on how to do it... http://www.imranulhoque.com/...-as-cron-in-windows/

The Forum post is edited by Steve Feb 24 '16
Alan Oct 31 '18
I for whatever reason can not even get this far and I have no idea why? Just told it's unable to handle the request
The Forum post is edited by Alan Oct 31 '18