We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

OxWall 1.8: Email function does not work even SMTP | Forum

Andreas Jan 4 '16
After the install I startet the cronjob an entered the information of my mailserver, but I always got an error. After that I checked all configuration of my mailserver, but this one is working fine (tested ist with other scripts).
Then i tried the phm_mailer testfile and it worked fine, but nothing happend when I want to confirm emails, or send mass-mails. I do not even receive the welcome-mail from system.
Could you help me please?
Marcel Jan 4 '16
you are correct the smtp settings?

ross Team
Andreas Jan 18 '16
@Marcel: Yes, smtp settings are correct, and also tested on other devices - working

@ross: Well, i tried the test.php and it worked, I checked the CRON and it works:

  • Cron #:4048 - cron job is active - Time of trigger: 22:40:02
  • Cron #:4049 - cron job is active - Time of trigger: 22:45:02
  • Cron is working an the ow_base_mail is empty after a turn, but no mail will be delivered.

    I will try again on SMTP even I will get an error while testing

    Andreas Jan 18 '16
    Nope, even with SMTP setting, that are working with other tools, do not send mail to the users. BUT ow_base_mail will also be empty after a turn.

    Is there something that I missed while I did the config? 

    but testing the phpmail funktion by a testpage, does work...

    helpless @ the moment

    Andreas Jan 21 '16
    Latest update:
    mhpmail is sending email to at least some users, I do not receive that mail.

    SMTP shows an error on connectiontest but is sending email to at least some users, I do not receive that mail.

    Strange, but I will not stop till I have found a solution.

    ross Team
    ross Jan 21 '16
    Andreas what kind of smtp you're using?
    Andreas Jan 21 '16
    my own Mailserver (Kerio)... But why you ask that question, it does not belong to the existing problem. Any user gets mail except me. But I think it workt fine till I tried to change mailadress

    ross Team
    ross Jan 21 '16
    and this mail server is the mail server of the hosting you're hosted on?
    The Forum post is edited by ross Jan 21 '16
    Andreas Jan 23 '16
    No, Ross, it is my own Mailserver in my house, and it works fine to all others with oxwall except me. 

    Other websites or CMS Systems do work fine and I do get all other mails. 

    So the ERROR MUST be part of my adminprofile in oxwall

    ross Team
    ross Jan 25 '16
    Andreas, can you please try to use Forgot password option? Do you get this e-mail? Keep us updated
    Andreas Jan 25 '16

    No... to the @swtor-rp.org I do not get any mail via oxwall, but the server works fine.

    When I change my own adress to a simple gmx-Adress I will get the mail (massmail).

    Now I would like to find out WHY!

    Jochen Sep 27 '17
    I have a similar problem:

    Registering and forgot password   is working fine, BUT:  Sending out Massmails does not work. Neither with or without SMTP the massmails are not sent.

    I am using Oxwall 1.8.4

    Anyone an idea ?  Thanks in advance, Jochen
    Jochen Sep 28 '17
    Hi Andreas, I found out the following:  for me it works as follows:

    Via  admin I enter my SMTP-details, click the save button, click the test button, all ok.

    Right after this, I send out a massmail.

    Right after this I MUST run the cronjob and then all mails are sent out.

    Without running the cron job NO emails are sent.

    Maybe this also works for you, br, Jochen