We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Installation error[Solved] | Forum

Jon
Jon Aug 2 '16
I am new to Oxwall and have searched these forums, but not found an answer to this. I have tried to install Oxwall using Softalicious, as well as manually, on a shared host (A Small Orange). I get the following error message:

Fatal error: Undefined class constant 'MYSQL_ATTR_INIT_COMMAND' in /home/resist10/public_html/ssssss/ow_core/database.php on line 196


I have tried installing in a subdomain and in a directory.

I have tried to activate  PDO in php.ini:

extension=pdo.soextension=pdo_sqlite.soextension=sqlite.soextension=pdo_mysql.so

Running PHP 5.5

ASO customer service tells me PDO is active on my sites.

I'm just clever enough to be dangerous, but don't know what to try next. I have a feeling that the problem is with my hosting service, but was hoping someone here could help me understand better what I need to be asking.

Oh, one more thing. When I try to install using Installatron, I get the following message, which leads me to think I'm still having issues with PDO, which frankly, I am not familiar with.
Select the version of Oxwall to install.Version1.8.3 (requirements not met) (recommended)1.8.1 (requirements not met)1.8.0 (requirements not met)1.7.5 (requirements not met)1.7.4 (requirements not met)1.7.3 (requirements not met)1.7.2 (requirements not met)1.7.1 (requirements not met)1.7.0 (requirements not met)1.6.0 (requirements not met)1.5.3 (requirements not met)1.5.2 (requirements not met)1.5.1 (requirements not met)1.5.0 (requirements not met)1.4.1 (requirements not met)1.4.0 (requirements not met)1.3.2 (requirements not met)1.3.1 (requirements not met)1.3 (requirements not met)1.2.6 (requirements not met)! The selected version 1.8.3 is not compatible with the selected install location.

Requirements:
php-pdo-mysql-version-minimum v1 (detected: OFF)
Thanks in advance for your patience and any help you can offer.

The Forum post is edited by ross Aug 14 '16
Darryl B Leader
Darryl B Aug 2 '16
You can see a list of requirements by going to the link below. That would be the first place to start. It looks like the hosting may be falling short of some of these.

https://developers.oxwall.com/hosting
dave
dave Aug 2 '16
I looked at the plans, it looks like they all use suPHP


  • PHP 5.4, 5.5 and 5.6 support with Composer in an suPHP secure environment


make sure you check your version of php using ONLY phpinfo()


The Forum post is edited by dave Aug 2 '16
Jon
Jon Aug 3 '16
OK. Thanks, guys. Back to customer support.... or one of Oxfall's recommend hosting services, I guess.

I appreciate the prompt responses.


Aliya Team
Aliya Aug 4 '16
thank you for helping Darryl B  and dave

Jon if you do not want to deal with any installation or hosting related matters you can simply order all services from oxwall.com
Jon
Jon Aug 4 '16

Quote from Aliya thank you for helping Darryl B  and dave

Jon if you do not want to deal with any installation or hosting related matters you can simply order all services from oxwall.com
That is an option I am considering. I want to evaluate Oxwall for a project I'm  responsible for. I have been satisfied with my current hosting service until now. Changing hosts will be a hassle at best and a major ordeal at worst. I manage several sites and nearly a dozen domains. All small potatoes, but a whole basket of them!

:-)


Jon
Jon Aug 4 '16
To their credit, ASO finally got the install to work. Unfortunately I failed to save a copy of the fix, but it did involve the pdo and required adding a php,ini file to the directory containing the Oxwall install.

I am sharing this in case anyone else with the same problem finds this thread. I had a heckuva time tracking down the source of the problem. Bottom line: contact your host for support and don't allow them to blame Oxwall. It IS a configuration issue.

I am definitely looking at other hosting services. ASO is my third host in about ten or more years of managing mostly self-hosted WordPress sites. Another move is not something I look forward to doing again unless I have to.

Now it's time for me to really play around with Oxwall to determine whether it will meet my needs. FWIW, I am considering it because it appears to offer everything I'm looking for out-of-the-box, unlike BuddyPress, which I have also been experimenting with because I've grown comfortable with WordPress. I can't believe how complicated and user-unfriendly that product is. Wish me well with Oxwall. I am impressed with this first encounter for support.

Thanks again for your patience with a newbie.


dave
dave Aug 4 '16
You are very welcome Jon, glad to have you aboard and let us know if you should have any other questions.  The volunteers like myself or the team members will be happy to assist you.  :)