We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

PHP Fatal error: Call to undefined method Updater | Forum

Александр
Александр Aug 10 '16
Update event error 500
[Wed Aug 10 18:12:26 2016] [error] [client 192.168.0.2] PHP Fatal error: Call to undefined method Updater::getSeoService() in /home/...../web/......./public_html/ow_plugins/event/update/10606/update.php on line 33, referer: http://......./...e-request/key/event/
dave Team
dave Aug 10 '16
the update for the event plugin is not finding the called getSeoService function for some reason, i am not sure why.  But that is the issue. 


What version of Oxwall are you running and what version of php do you have, check your php using ONLY phpinfo()  



ross Team
ross Aug 14 '16
Alexander, 


seems like you updated plugin before doing platform update, is that so? 

Александр
Александр Aug 17 '16
the platform is not updated 

does not allow php version

in plug-ins do not have php validation???

It hung in the maintenance mode, the system

Александр
Александр Aug 17 '16
PHP 5.4.45-0+deb7u1


the upgrade is not checking php, there may be problems

The Forum post is edited by Александр Aug 17 '16
dave Team
dave Aug 17 '16
Oxwall now requires php 5.5 minimum.  You need to restore your site from backup, increase your php version to 5.5 and then read here and follow the instructions. 


https://developers.oxwall.com/forum/topic/24133


i personally deactivate all plugins not just third party plugins. 

ross Team
ross Aug 18 '16
Alexandre, you get this error, because your platform needs to be updated first, up your php version, and update your platform please
Александр
Александр Aug 18 '16
Easy to say but hard to do

It is necessary to put a new version of debian

the easiest way, hosting panel with the problem, it's easier to reinstall all

otherwise it is a dance with a tambourine

which version works on 5.4

take another hard disk will reinstall the system

dave Team
dave Aug 18 '16
the last version to work on 5.4 was 1.8.1 i believe



https://github.com/oxwall/oxwall/blob/master/CHANGELOG.txt  


 if you go down to 1.8.2 you will see they set the default min to 5.5  so you would need to go with 1.8.1 the version before that

The Forum post is edited by dave Aug 18 '16
Александр
Александр Aug 25 '16
I will reinstall the system

debian 7 -> 8


Alan
Alan Jan 2 '18
I have the same issue and yes I attempted to update the plugin first like an idiot lol, php is 5.6 and version is 1.8.2 (build 10400)
The Forum post is edited by Alan Jan 2 '18