We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

smtp not working | Forum

Max Sep 14 '16
Hi, Im new in oxwall, Im trying to set the site to only invite, but the mail is not working, I enable the smtp and fill with my info but I got this message SMTP Error: Could not connect to SMTP host.

I searched here in the forums and I find the google config but when I tried with the google smtp config I got this

<html><head><title>500 Internal Server Error</title></head><body>

<h2>Request Timeout</h2>

<p>This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'.



The installation was made with softacolus and the cron job is this wget -q -O /dev/null http://mydomain.com/oxw1/ow_cron/run.php all with * * * * *

any suggestion? thx in advance.

The Forum post is edited by Max Sep 14 '16
ross Team
ross Sep 15 '16
Hello Max, 

Let's start with contacting your hosting provider regarding 500 Internal server error and request to increase your connection timeout. 

After that, please try the smtp details you used on our demo website. Do you get the same there? 

Keep us updated. 

admin Nov 8 '16
Hi there,

The SMTP setting works and i get successfuly connected message on demo.oxwall.

however same setting failed on my own website.

what could be the reason?

I appreciate any guess and help.

admin Nov 8 '16
I didnt know about php mail function, thanks Chris for telling me about it.
Where i can find php mail setting among oxwall files?
which one is more secure or better to use? (Smtp or php mail)
dave Leader
dave Nov 8 '16
I believe the software defaults to php mail so you dont need to do anything to set it.  SMTP is typically more secure.  The -O in your cron you can get rid of its not used anymore that i know of.   How are you entering your SMTP details

for example: 

host.example.com     465


pw  (make sure your password does not have a $ in the first position)


is that how you are entering it.. that format

The Forum post is edited by dave Nov 9 '16
dave Leader
dave Nov 9 '16
Yeah sorry my bad, i guess my head went in the twilight zone for a minute... 

I have corrected the post lol... thats what happens when you try to watch the election and type at the same time.. :0

The Forum post is edited by dave Nov 9 '16
admin Nov 11 '16
Thanks Dave & Chris..
Issue was related to the server and finally it was fixed by technical support.

Now, its working with SMTP but i will keep working on PHP mailer as you guys mentioned it will be better.
Thanks a lot
dave Leader
dave Nov 11 '16
Thank you for letting us know, and glad you got it fixed :)