We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

images not appearing after upload. [Solved] | Forum

danny
danny Jul 16 '12

There is no default avatar picture and when attempting to upload an avatar or a picture it does not appear.

 

aquaristhub.com....take a look

The Forum post is edited by Alia Apr 8 '13
danny
danny Jul 16 '12

I can not get it to work can somone please help me out?????????

 

Even default images are showing up as broken image

danny
danny Jul 17 '12

Got the fix myself I figured it out here it is if anyone is looking

 

Problem in .htaccess file. I solved this problem so ow_userfiles/.htaccess rewrite code in file. Instead Options All -Indexes, write it Options -Indexes

Nicholai
Nicholai Apr 5 '13
i HAD THE SAME PROBLEM THANK YOU FOR FIGURING IT OUT I DID AS YOU SAID AND ISSUE SOLVED.
Hisham Elkhatib
Hisham Elkhatib Apr 29 '13
I had same problem as my hosting is hared godaddy and above solution solved the problem. Thanks.
Nathaniel Moikabi
Nathaniel Moikabi Nov 17 '13
Thank you danny, you are a star.
Hadi Kamell
Hadi Kamell Nov 7 '14
Thanks dear Danny :-)
Bhavika Rugnath
Bhavika Rugnath Mar 19 '15
this didnt solve my problem
ross Team
ross Mar 19 '15
Bhavika, do you also not see the images after uploading?

What is your software version?

What is your photo plugin version?

What are the permissions on the ow_userfiles folder, ow_pluginsfiles, ow_static, ow_smarty/templace_c

What theme are you using while uploading photos?

Have you made any modifications to .htaccess, any other files?

Jim
Jim Oct 15 '16
Reviving this topic, I'm using x10hosting and I have the 'Fantasy' theme. I also have a special header image.


I used the solution here and the pictures I loaded were then displayed but the header image disappeared and reverted to the standard header background.


I commented out 'deny from all' in the htaccess file in the 'ow_themes' directory and both my images and the special header image were displayed, until the following morning when the profile images disappeared again.


Changing these values seems to refresh the display but it doesn't stick permanently.


Also after changing these values applications can no longer be made from a mobile (although this may be a red herring).


So, can anyone suggest why these combinations don't work or what might be the correct combination or a better solution?


Many thanks

ross Team
ross Oct 17 '16
Share your url, make sure your site is open for registration. 
Jim
Jim Oct 17 '16
Hi Ross


sdn.x10host.com


I've opened the site for registration, it would normally be by invite only and no viewing by guests.


Thanks

ross Team
ross Oct 17 '16
When you go directly to the image: http://sdn.x10host.com/..._1_5804b934aee30.jpg


we get 500 internal server error, this is a server related issue, contact your hosting provider to resolve it. 

Jim
Jim Oct 18 '16
Thanks.


Haven't had a response from x10 but I'm still wondering why when I change the htaccess for photos to options -indexes both the photo and the header image image appear, then after a while refresh the page and the header image disappears, then change it back to options all -indexes the photo disappears again while the header image remains. Is the server error likely to be caused by changes in the htaccess entry?

ross Team
ross Oct 18 '16
Probably, your server does not meet our requirements, which is why you have such a conflict. 


Keep us updated on the hosting's reply. 

Patrick Reed
Patrick Reed Aug 2

Got the fix myself I figured it out here it is if anyone is looking

 

Problem in .htaccess fileI solved this problem so ow_userfiles/.htaccess rewrite code in file. Instead Options All -Indexes, write it Options -Indexes


This worked perfectly. I have spent days trying to figure out why it would not allow me to change anything. Thank You.

dave Team
dave Aug 2
Ross was correct, if you have to change that value in the htaccess file then you have another issue at hand.  
Patrick Reed
Patrick Reed Aug 2
So, it resolved the upload problem, but made the site unavailable to anyone except the admin. Setting it back and gonna see what happens.
Patrick Reed
Patrick Reed Aug 2
It was conflicting with the Facebook connect app. Disabled that app and everything seems to be working fine with the change in the ow_userfiles/.htaccess. I know this will lead to bigger problems and I have no idea how to fix it. For now I am leaving the app disabled so that I can continue trying to finish designing this website. Other than that I am kinda at a loss. 
Patrick Reed
Patrick Reed Aug 2
My site is registered through godaddy, but it sits on a private server. Im not sure where the problem is at. Any suggestions? Everything is back to the way it was installed Oxwall latest version, Facebook go theme (although I have the same issue with all themes), all settings look good but when the ow_userfiles/.htaccess is set to Options All -Indexes I can not make any visuall changes at all. no theme visual change because I am unable to upload photos at that time.I checked the permissions on the files listed above and they are set to 777. Thank You 


www.zypitz.com

Pages: 1 2 »