We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Can't upload Pictures (Photo Plugin) | Forum

nope nope
nope nope Oct 17 '16
Hello,

a few days ago i migrated from a web hosting account to my own vServer, i've installed php5 with all necessarry mods. But I just cannot upload Photos anymore, everything else works fine.

- Tried to troubleshoot with Firebug:
Error: uncaught exception: parsererror

- Tried to fix it with DEBUG/DEV Mode
Error:
chmod(): operation not permitted  ow_utilities/file.php line 98

- Reinstalled photo plugin

- Set 777 rights to all necessary folders/files

- Screenshot of PHPinfo http://fs5.directupload.net/images/161017/ywzqrjkl.png

I have no idea what the problem could be... I am running Debian 14.04

Any ideas?

The Forum post is edited by nope nope Oct 17 '16
ross Team
ross Oct 18 '16
Make sure 

ow_pluginfiles

ow_static

ow_smarty/template_c

ow_userfiles


folder have 777 permissions set recursively. 


Do not enable debug and dev modes at the same time. Only one at a time. 


After setting permissions, enable dev mode and refresh your website. See if the issue persists. 


If it does. Share your url. Make sure your website is open for registration and there's no any mandatory approve of users enabled.

nope nope
nope nope Oct 18 '16
Hello, i've set the permissions again, and activated the DEV mode then i am recieving this error.



After Reloading the Page the error was gone, and picture uploading works too..
The Forum post is edited by nope nope Oct 18 '16
ross Team
ross Oct 18 '16
Don't worry, this is the error you get when the template recompiling  and static cache clearing take place. 


I believe you won't see this error again, after site totally loaded. 

Please disable dev mode, otherwise you site will be slow. 


So your issue with the photos is resolved? 

nope nope
nope nope Oct 18 '16
Yeah its resolved now, thank you very much.
ross Team
ross Oct 18 '16
Great, thanks for letting us know. 
Graham
Graham Dec 21 '16
Hello I am having a similar trouble, When my authorized users click Add Photo, We all see a type of loading bar, that changes color. Nothing else happens.   


My users can Add photos by the News Feed posts but only in posts. It is impossible for anyone to add photos through the Add Photo button on the right side.


Google chrome debugger says 


 https://vighorusgames.com/...r=0.6296689915883362 Failed to load resource: the server responded with a status of 403 (Forbidden)


I have set permissions to 777 as mentioned and enabled Debug Mode or Dev mode seperate, even with them both off this does not work.   I am using an up to date Oxwall and plugins.  NO custom code  on this site.



Any suggestions to fix it?   Thank you!

The Forum post is edited by Graham Dec 21 '16
nope nope
nope nope Dec 26 '16
Try to install php5-gd, it fixed my problem.
Graham
Graham Dec 28 '16
FIXED. 

I found another topic,  It  was a problem with my Web hosting mod security.  

I sent them a ticket with this, a test account on my site to reproduce it. 

Here is what I sent them from the other topic 

Experience from others indicate the following ModSecurity rules may need to be disabled or modified:

340147
340162
340148
350147
350148
350149
dave Leader
dave Jan 5 '17
Sometimes cloudflare settings can also cause such an issue. Glad you got it resolved.
Oxwall Türkiye
Oxwall Türkiye Feb 8 '17

Infinite loop error

The screen does not open for adding pictures.

Continues in infinite loop

What kind of permission is necessary for this situation.




This problem began with the first OXWALL experienceI did not know what the required permissions wereThe picture insert box has not been opened for 3 years.I can not get an answer to this question.

Attachments:
  2017-02-08_19-20-36.png (481Kb)
razz noir
razz noir Feb 10 '17
I have been battling with this issue myself. I scoured this post, and altered the 0755 permissions to 0777 for...
- ow_pluginfiles
- ow_static
- ow_smarty/template_c
- ow_userfiles

Was really excited, but nothing changed, I still get the constant 'load' image. Now. I can open a New Album and upload images just fine, but it wont let me add to them after the fact.

Platform version 1.8.4 (build 10800)

I'm also having no luck with the Video option, or increasing the Display Picture from 2mb to more. Although I suspect I'll have to contact my server host for those.

Please, please please hit me back. I'm itching to get this setup for my community.
dave Leader
dave Feb 10 '17
Do you use cloudflare? 
razz noir
razz noir Feb 12 '17
There is an option to activate it through the Cpanel. Although i haddn't yet. Would activating that help?
dave Leader
dave Feb 13 '17
NO dont do anything yet, some features from cloudflare can cause issues, i use it but on a limited basis.  
razz noir
razz noir Feb 13 '17
Ok. lol.
I've never run into issues when putting up SMF or others, but I've changed hosts since then. I'm pretty certain it's htaccess or other core file settings. If it is, I'll have to ask them to raise some limitations I think.


lisa
lisa Sep 13 '19

hello

i am having same issues

i have ver 1.8.4

cant upload pics

also when i tried the patch from some softwre that seems to be a distro of oxwall 1.84

i do upload pics but i cant comment with pics on my profile page

becaue what happens is the comment disappears after refresh the brpwser



lisa

Duverney
Duverney Nov 9 '21

the PHOTO plugin stays Iterating and blocks the Program.

Switch to the Current Version

PHP 7.3.32.

and the problem continues.

I am having same issues

I have ver 1.8.4  cant upload pics.

Patricia Zorrilla Leader
Patricia Zorrilla Nov 9 '21

Download the latest versions of OxWall and its plugins here:

https://owspain.com

Especially if you use PHP versions higher than 5.6

Don't expect help in this forum. The developers left, the moderator left and the users are leaving, that's why there is only spam.

ashlee
ashlee Dec 3 '21
Hi,


With Woocommerce Product Video plugin you can add, YouTube videos, Vimeo videos, daily motion videos, and self-hosted videos.