We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

RSS widget not updating | Forum

Barry Horning
Barry Horning Oct 31 '16
I have tried to use the RSS widget on the main page and it will initially display the information from the RSS feed but then does not update. I guess the downloaded information is cached somewhere but (despite searching the forum for a similar topic) I cannot for the life of me sort it out. Version 1.8.4 is running well except for this.

Any advice please
The Forum post is edited by Barry Horning Oct 31 '16
dave Leader
dave Oct 31 '16
Hi Barry, sorry your having issues with the RSS. I myself dont use the RSS but Ross will be in the office in about 8 hours or so and he should be able to shed some light on this for you.  

Barry is this from a wordpress RSS feed?

I did find this Barry i hope it helps... 


The Forum post is edited by dave Oct 31 '16
ross Team
ross Nov 1 '16
provide your rss feed url please
Barry Horning
Barry Horning Nov 1 '16
I have tried several but these are the two main ones:

 Both intially feed the information but neither updates once the initial information downloads. Neither have ever given a problem when used with other readers
Barry Horning
Barry Horning Nov 1 '16
I have tried the workaround in https://developers.oxwall.com/forum/topic/14554 without any success
ross Team
ross Nov 3 '16
Barry We have added your RSS feed on the November 1. Please see screenshot. The feed is updating. 

Can you please share your url? 

  Screenshot from 2016-11-03 14:44:07.png (683Kb)
Barry Horning
Barry Horning Nov 3 '16
Hi Ross,
URL of site is grampianhilltoppers.co.uk, it is a membership only site so will send you access details with full admin rights by PEM.

Could it be the theme that is stopping it updating?
ross Team
ross Nov 4 '16
Rebecca +1 

Barry your cron is not properly configured. 

I ran it manually and your rss has updated. 

Please configure your cron properly according to the manual: https://wiki.oxwall.com/install:cron

Barry Horning
Barry Horning Nov 4 '16
Hi Ross,

Cron is set to 1 minute update (wget -q -O /dev/null http://grampianhilltoppers.co.uk/ow_cron/run.php) but the widget you placed on the page is still showing feeds from over 5 hours ago. I have moved the feed off the page again until I can see what is happening


PS updates if I run the Cron job manually. Is this a hosting problem?
The Forum post is edited by Barry Horning Nov 4 '16
dave Leader
dave Nov 4 '16
try  php -q /dev/null/......   

-q means quiet mode so no output, -O i dont believe is used anymore you can probably drop that, and php -q works for me but im on cpanel so mine is like this 

php -q  /home/username/public_html/ow_cron/run.php   

might not work on your system config 

The Forum post is edited by dave Nov 4 '16
Barry Horning
Barry Horning Nov 5 '16
That did it! Now running correctly.

Thanks for all your help
ross Team
ross Nov 6 '16
Thanks for letting us know.