We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Foreign character in profile question url not validated ? | Forum

Carsten Dec 15 '16

I need to use a profile question for website url.

I'm in Denmark and some sites uses danish letters in their url for their website, but Oxwall will not validate it.

How can i get it to validate ?

All the best
dave Leader
dave Dec 15 '16

Are you using URL for the answer type in your question?

Carsten Dec 16 '16
Hi Dave

Yes i am, so it's the validation there that gives the problem.

When using another text field, it also gives problems, but not validating errors. It just breaks the link feature when reaching the foreign characters, so that maybe it will create and link to the half of the url.
dave Leader
dave Dec 16 '16
I believe the URL option is validated as URL but the other fields are not validated that i know of other than maybe integer values.   

Is there a particular reason why you need to have a special language character in the URL?

Carsten Dec 16 '16
It's just how the danish language is, we have those three weird ones " æ - ø - å " ;-)

The problem is, that they are not internationally recognized, so if the software doesn't take them into account, there's problems. Well, it's a half truth. Regarding url, they can be used, but looks like crap when translated into "international" url language. And the whole mail thing don't work.

I would like to be able to use the link feature, so that users just can click it and go to that site. I can't now, the link stops at our special characters. So how can i fix this ?

EDIT: I believe that Swedes will have the same problem be course they use " å ".
The Forum post is edited by Carsten Dec 16 '16
Carsten Dec 18 '16
How can i get Oxwall to accept foreign characters so my links can be clickable ?
OW-Ghost Dec 18 '16
i have same issue, when i try seo my urls and create new pages with foreign letters. then it will not accept foreign language letters in the url option when create new pages.

yes sweden same issue and asian letters and some other countrys

i hope they will fix this in next update 1.8.5 


The Forum post is edited by OW-Ghost Dec 18 '16
dave Leader
dave Jan 5 '17
I would not expect Oxwall to recognize them if its not recognized internationally, you may have to get some custom coding done in order to accept the local special characters.
Carsten Jan 5 '17
Isn't just a character set settings problem ?

The Latin-1 has the characters needed.
dave Leader
dave Jan 6 '17
I suppose you could test this by converting some of the tables to Latin-1 in a test environment, but i would not do that on a production environment. 
Carsten Jan 7 '17
So there's no place in the code where there is a setting controlling this ?
dave Leader
dave Jan 7 '17
There may be, but look at it this way.  Even if you change it in the html files or any of the front end files, the database is only going to store is as UTF-8 because the table is set up as UTF-8  so it wont matter, you still wont get the characters stored. 
Carsten Jan 7 '17
That i understand, but it will not help change the tables in the database if there's a setting in the code somewhere that blocks the understanding of the characters i type in.

But i'll try changing the tables and see how that goes :)