We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Deactivated and Deleted Plugin, Cleared Cache, Re-Uploaded Plugin and... Same Data?! | Forum

Blaire Dec 3 '17
I'm rather long-winded usually so I tried to recap what I mean in the title for a quick overview.

So, I have the Location Maps plugin. It's worked well up until this last update. There was an issue where the update somehow made buttons (such as the Message button) on the site stop working completely. Blah, blah, blah I was trying to troubleshoot it on my own because none of the plugin developers I've tried to contact when I've had issues in the past have actually responded to me. Really wonderful service.

Anyway, I got fed up with it and, ultimately, decided to completely remove the plugin and reupload a previous version I had before the last plugin update.
I deactivated the plugin.
I deleted the plugin using the Admin control panel.
I turned on DEV mode and DEBUG mode to empty the cache (per instructions I found here).
I activated these things both simultaneously and individually and gave them each about 10 minutes while on before turning them back to false. So, 30 minutes just assuming to clear the site cache.

I took the former version of the plugin and then reuploaded it through the admin panel.
Then I navigated to the user profile fields section and saw that my customized text I had changed on the page was still there for that plugin. Just as if the plugin had never gone.

So, I removed (deactivated, deleted) it again.
I turned on DEV mode and DEBUG modes again (and then back off after 10 minutes).
I cleared my browsers' (Mozilla Firefox; Google Chrome) cache and cookies, completely restarted my computer. Kind of becoming desperate at this point as my users are starting to complain heavily about the missing plugin that was used very frequently.
So, I re-uploaded the plugin file yet again and...boom. Exact same thing. Exact same customization is back again, still like it had never been deleted.

Obviously there is a cached file somewhere.
I log into my server via Filezilla.
ow_plugins has nothing for this plugin any longer (deleted the file for the plugin that still existed there)
ow_pluginfiles has nothing for this plugin any longer
It feels like I can't find a "cache folder" of some sort I could actually MANUALLY purge.

Now, I remember I had this exact same issue with another plugin about 2 months ago. I ended up deleting it and keeping it deleted for about a week and when I reuploaded it then all of the previous stuff had finally gone away. So, I don't feel this is a one-plugin-specific issue.

How can I truly clear the cache of the site? This is a bit silly and feels like it's much more complicated than it needs to be in removing a plugin.

I'm running Oxwall 1.8.4
And, sure, I have other plugins purchased from the Oxwall Store here.
NOT using a CDN.

...any ideas on how I can get this to disappear for good so I can re-install fresh without losing a massive amount of data by reinstalling the entirety of Oxwall?

Sorry for coming off a bit irritated. PMS + a few hundred unhappy users emailing me every hour for the past 2 days about how the location map has disappeared and they're oh so devastated is weighing on me at this point.
The Forum post is edited by Blaire Dec 3 '17