We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Listen Up Folks - Important Stuff Here | Forum

dave Leader
dave Feb 4 '18
EVERYONE SHOULD DO THIS! - it does not hurt anything and actually the cache extreme plugin does most of this but not all.  You just need to take it one step further to fix this possible issue. 


Everyone should delete all the files in their template_c folder and then delete the folder itself (when the site is not busy of course) 


The system will recreate the folder immediately and give it a permission sometimes 0771 sometimes 0755 and sometimes 0777.  If not 0777 just change it to 0777 and make it a recursive change (everything in that folder 0777) 


The cache extreme plugin triggers a function which deletes the files but it does not delete the folder, you need to do this manually. 


WHY!!  here is why...    And you should only have to do this one time! Unless you make more server changes. 


I have two oxwall sites, a test site and a live site, both on the same server.  Today i noticed that some of my language on one site was not the new stuff that i added in my update, but the testsite was fine and had the new text. 


So i worked on it today trying to find out what the deal was, i deleted my lang file in the plugin trying to get the plugin to fail and nothing, i tried running cache plugin and doing it manually, again nothing, i tried reuploading the lang file via admin lang section, nothing.. i even tried running some of the process directly in the database query, nothing.  


As a last resort i decided to break the system (to force it to update) by deleting the template_c folder completely.  After a second or two i went to recreate it and the system told me that it was already there. That is when i realized that the sytem recreates the template_c folder for you if its not there. 


And then it began to work when i ran the cache plugin.   


The reason why is this,  i believe without being too technical here.  Currently there is a rash of concerns with server kernels which are outdated and do not offer "race condition" coverage.  If you dont know what "race condition" is please google it as i dont want to go into all that here. 


If you are running cpanel you can check your kernel by running the security advisor in WHM, like many of us you probably have the unknown kernel installed.  But an updated kernel is on its way, but i dont know when. 


Now because of that security hole alot of people are putting their Cpanel accounts on jailed shell settings, and making other changes to try to protect themselves from this risk.  


Some of those changes effect file owner of the site, which is what i believe was the issue here.   Even though i checked the owner info and it said it was the Cpanel username who was the owner.  I believe that somehow during the changes to secure the site such as the file protection setting and many others, it  is messing up the ownership of the template_c folder. 


So when i deleted the folder and the system recreated the folder, then all was set correct again.  That is why it works now. 


Again this does not hurt your oxwall install or your system in any way and if you do have the problem then this will correct it.  If you dont then there is nothing lost by doing this. 


This means that if you have this issue you may have some language on the users side and admin side that you dont see.   I noticed this last week when i was helping some of my customers i did wonder why they just updated the plugin and all went well but yet the new language i just added was not there.  And this is why. 


So again, please delete all the files in the template_c folder, then delete the folder itself, then let the system recreate it, then set it back (recursively) 0777 and your done.  


Hope that helps someone :)

The Forum post is edited by dave Feb 10 '18
John
John Feb 9 '18
Where do I find the templates_c folder?  I can't seem to locate it in file manager
dave Leader
dave Feb 10 '18
hi its in ow_smarty folder  and sorry i had a typo its template_c  ill correct my post. 
Tesla Kuhn
Tesla Kuhn Jan 7
Would this fix my perpetual, yellow padlock issue despite having ssl on my site?
Oxwall Germany Club
dave Leader
dave Jan 7

Quote from Tesla Kuhn Would this fix my perpetual, yellow padlock issue despite having ssl on my site?

No it does not have anything to do with that.  


You are getting the yellow padlock because something on the page load is not using https such as images, css links, other links or widgets.  Check your page source on the page to see what is being loaded via http and youll probably get back to green lock.    


Depending on your server and setup there are ways to force everything to load https. 


Hope that helps.