We build. You grow.

Get best community software here

Start a social network, a fan-site, an education project with oxwall - free opensource community software

Installing php 7.1 mysql issue | Forum

dave Leader
dave Aug 23 '18
I wanted to document this issue for the future as i was not fully aware of exactly what the issue is. But after installing Oxwall on my test site using php 7.1 i know now the issue. 


Installation message: 


  Your hosting account doesn't meet the following requirements:

  • mysql PHP extension not installed

Please correct these before you can proceed with Oxwall installation. Complete server requirements list and compatible hosting can be found at Oxwall.org/hosting

Site Database Install   

   
Reason: In the Cpanel php 7.1 config there is no mysql option as the base mysql has been deprecated for a long time now.  So logically if you cannot enable or disable mysql in the php config then it becomes an issue. 


WHY:  because Oxwall is an older software which was around when mysql was still supported.  So the install code checks for the presense of mysql during install. If it is not there then it is flagged. 
Fix:  The install code needs to be updated to check for php version first. If the version is 7+ then the mysql check needs to be skipped.  


Work Around: Until the script is updated you can install Oxwall using php 5.6+ and then update your server to php7.1 


DO NOT USE PHP 7.2 as Oxwall is not ready for that yet and will fail.    


Other notes:  If you have Cpanel you want to be sure the following are checked in the PHP 7.1 config.  It is better to be safe than sorry so i have checked more than i need here but i did so just in case.   













nd_pdo_mysql from what i understand only comes with Cpanel and is their exclusive mysql extension. 
hope this helps, if i get a chance to update the install i will share my code.        

The Forum post is edited by dave Aug 28 '18
dave Leader
dave Aug 23 '18
And here is the fix.... 


What i did was added some code that checks if the php version is greater than 6 then remove the mysql extension requirement from the check process. 


I just tested this on install and it works. Here is the new file.   This file goes in ow_install/controllers folder



The Forum post is edited by dave Aug 23 '18
Attachments:
  install_php.zip (4Kb)
AppXprt
AppXprt Aug 23 '18
Awesome! Getting this into OxNext tonight.
dave Leader
dave Aug 28 '18
Ill try to commit this tonight.. :)
Webster Molaudi
Webster Molaudi Aug 28 '18
Hi Dave,


I had to go back to Php 5+ because some plugins i bought dont support Php 7 so another thing to consider. 


If there was a way like they show Oxwall Version on plugin page we could also see what Php version the plugin support.

The Forum post is edited by Webster Molaudi Aug 28 '18
dave Leader
dave Aug 28 '18
That is alittle bit trickier, the main reason is because php changes and deprecates items all the time.  Usually those items are still supported for a long time before they officially pull the plug.  So some of the errors we get now are things that were put into place a long time ago.  People always way till the last second to update their code so then people get alot of errors all at once thinking its php but its not, its the developer  not updating their code. 


So the main reason is that we cant capture the exact date when the items switch will be turned off and no longer supported.  All we can do is wait for an error message.  And also there are too many to keep up with,  there would have to be almost daily updates and noone wants that. 


The only thing that can be done is to have a store moderation system in place to be sure that the developers take care of their plugins.  


Oh and by the way most of those claims on the plugins working with older versions are not even tested. Devs just check whatever box they want to support but its not tested on those versions.  And there is no way that oxwall has the manpower right now to verify it working with those versions of not.

The Forum post is edited by dave Aug 28 '18